summaryrefslogtreecommitdiff
path: root/recipes/udev/udev-static-devices.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/udev/udev-static-devices.bb')
-rw-r--r--recipes/udev/udev-static-devices.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/udev/udev-static-devices.bb b/recipes/udev/udev-static-devices.bb
new file mode 100644
index 0000000000..f0aab5a6a2
--- /dev/null
+++ b/recipes/udev/udev-static-devices.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Provide per-machine static nodes of /dev"
+RDEPENDS = "udev"
+
+PR = "r0"
+
+SRC_URI = "file://udev_static_devices_tarball"
+
+FILES_${PN} += "${base_libdir}/udev/*"
+
+do_install () {
+ install -d ${D}${base_libdir}/udev/devices
+ if [ -s ${WORKDIR}/udev_static_devices_tarball ]; then
+ install -m 0644 ${WORKDIR}/udev_static_devices_tarball ${D}${base_libdir}/udev/devices.tar.gz
+ fi
+}
+
+pkg_postinst () {
+ ROOT="$D"
+ if [ -f "$ROOT/lib/udev/devices.tar.gz" ]; then
+ tar -C "$ROOT/lib/udev" -zxf "$ROOT/lib/udev/devices.tar.gz" || exit $?
+ fi
+}