summaryrefslogtreecommitdiff
path: root/recipes/tickypip/tickypip-levels_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tickypip/tickypip-levels_1.1.bb')
-rw-r--r--recipes/tickypip/tickypip-levels_1.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/tickypip/tickypip-levels_1.1.bb b/recipes/tickypip/tickypip-levels_1.1.bb
new file mode 100644
index 0000000000..91938cf2e6
--- /dev/null
+++ b/recipes/tickypip/tickypip-levels_1.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Tickypip levels from NetWalk Group"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "${PN}"
+SRC_DISTRIBUTE_LICENSES += "${PN}"
+AUTHOR = "NetWalk Group <netwalkgroup@hotmail.com>"
+RDEPENDS = "tickypip"
+PACKAGE_ARCH = "all"
+PR = "r1"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-levels_${PV}.tar.bz2"
+
+S = "${WORKDIR}/"
+
+#
+# Authors response to LICENSE question:
+#
+# You may distribute them for free provide that you have links to our level
+# packs in PalmGear.
+#
+# Packs available on PalmGear: Pak1, Pak3, Pak8, Pak9, Pak10
+#
+# URL: http://palmgear.com/index.cfm?fuseaction=software.developer&userID=862314499
+#
+# I also got permission to distribute rest of levelpacks which was available
+# from Palm Gaming World:
+# http://www.palmgamingworld.com/add-in/netwalk.shtml
+#
+
+do_install () {
+ install -d ${D}${palmtopdir}/share/tickypip/levels
+ install -m 0644 levels/* ${D}${palmtopdir}/share/tickypip/levels/
+}
+
+FILES_${PN} = "${palmtopdir}/"