summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-xdctools-native_3.10.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-xdctools-native_3.10.03.bb')
-rw-r--r--recipes/ti/ti-xdctools-native_3.10.03.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/ti/ti-xdctools-native_3.10.03.bb b/recipes/ti/ti-xdctools-native_3.10.03.bb
new file mode 100644
index 0000000000..1d6ee675b5
--- /dev/null
+++ b/recipes/ti/ti-xdctools-native_3.10.03.bb
@@ -0,0 +1,21 @@
+inherit native
+require ti-xdctools.inc
+
+# download xdctools_setuplinux_3_10_03.bin from https://www-a.ti.com/downloads/sds_support/targetcontent/rtsc/xdctools_3_10/xdctools_3_10_03/index_external.html and copy in Arago (or OE) download directory
+
+SRC_URI = "http://install.source.dir.com/xdctools_setuplinux_3_10_03.bin"
+BINFILE="xdctools_setuplinux_3_10_03.bin"
+
+S = "${WORKDIR}/xdctools_3_10_03"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "310"
+PR = "r16"
+
+do_stage() {
+ install -d ${STAGING_DIR_NATIVE}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR_NATIVE}/${PN}
+}
+
+AUTOTOOLS_NATIVE_STAGE_INSTALL="1"
+