summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-codecs-omap3530_1.00.01.44.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-codecs-omap3530_1.00.01.44.bb')
-rw-r--r--recipes/ti/ti-codecs-omap3530_1.00.01.44.bb112
1 files changed, 71 insertions, 41 deletions
diff --git a/recipes/ti/ti-codecs-omap3530_1.00.01.44.bb b/recipes/ti/ti-codecs-omap3530_1.00.01.44.bb
index 6b31f26734..55295b347a 100644
--- a/recipes/ti/ti-codecs-omap3530_1.00.01.44.bb
+++ b/recipes/ti/ti-codecs-omap3530_1.00.01.44.bb
@@ -1,57 +1,87 @@
-require ti-codec.inc
+DESCRIPTION = "TI Codecs (and Server Combo) for OMAP3530"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent"
+SECTION = "multimedia"
-SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/DVSDK_3_00/3_00_02_44/exports/cs1omap3530_setuplinux_1_00_01-44.bin;name=cs1omaptarball"
+# TODO :: Move to common .inc (omap3 and omapl ready)
-SRC_URI[cs1omaptarball.md5sum] = "4db567252e6c43119e1c0aafe401a679"
-SRC_URI[cs1omaptarball.sha256sum] = "e042e1aad42a6728adf5c955dc38e4f8331fc0eacd833f1cd75d9cbb4faff0b5"
+PV = "1_00_01_44"
-# Specify names of the InstallJammer binary file and the tarball it extracts
-BINFILE = "cs1omap3530_setuplinux_1_00_01-44.bin"
-TI_BIN_UNPK_CMDS = "Y:Y: qY:workdir"
+SRC_URI[omap3codecsbin.md5sum] = "4db567252e6c43119e1c0aafe401a679"
+SRC_URI[omap3codecsbin.sha256sum] = "e042e1aad42a6728adf5c955dc38e4f8331fc0eacd833f1cd75d9cbb4faff0b5"
+PR = "r7"
+
+require ti-paths.inc
+require ti-staging.inc
require ti-eula-unpack.inc
+PROVIDES += "ti-codecs-omap3530-server"
+RREPLACES_${PN} = "ti-cs1-omap3530"
+
S = "${WORKDIR}/dvsdk_3_00_02_44/cs1omap3530_1_00_01"
-DEPENDS="ti-codec-engine ti-linuxutils"
-RREPLACES_${PN} = "ti-cs1-omap3530"
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/DVSDK_3_00/3_00_02_44/exports/cs1omap3530_setuplinux_1_00_01-44.bin;name=omap3codecsbin"
-export CODEGEN_INSTALL_DIR
+BINFILE = "cs1omap3530_setuplinux_1_00_01-44.bin"
+TI_BIN_UNPK_CMDS = "Y:Y: qY:workdir"
-# Yes, the xdc stuff still breaks with a '.' in PWD
-PV = "1_00_01_44"
-PR = "r6"
+DEPENDS = "ti-cgt6x ti-xdctools ti-dspbios ti-codec-engine ti-linuxutils"
+
+#generic codec
+DSPSUFFIX_omap3 = "x64P"
+
+do_prepsources() {
+
+ make \
+ CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ CODEC_INSTALL_DIR="${S}" \
+ XDCARGS="prod" \
+ clean
+}
+
+addtask prepsources after do_configure before do_compile
do_compile() {
- make CE_INSTALL_DIR=${CE_INSTALL_DIR} \
- FC_INSTALL_DIR=${FC_INSTALL_DIR} \
- LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
- CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
- LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
- BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
- CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
- XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
- CODEC_INSTALL_DIR="${S}" \
- XDCARGS="prod" \
- clean
-
- make CE_INSTALL_DIR=${CE_INSTALL_DIR} \
- FC_INSTALL_DIR=${FC_INSTALL_DIR} \
- LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
- CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
- LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
- BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
- CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
- XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
- CODEC_INSTALL_DIR="${S}" \
- XDCARGS="prod" \
+ make \
+ CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ CODEC_INSTALL_DIR="${S}" \
+ XDCARGS="prod" \
+ all
}
-do_install () {
- install -d ${D}/${installdir}/codec-combo
- cd ${S}
- for file in `find . -name *.x64P`; do
- cp ${file} ${D}/${installdir}/codec-combo
- done
+do_install() {
+
+ install -d ${D}/${installdir}/ti-codecs-server
+ cd ${S}
+
+ # Install the DSP Server Binary
+ for file in `find . -name *.${DSPSUFFIX}`; do
+ cp ${file} ${D}/${installdir}/ti-codecs-server
+ done
+
+ # Install docs (codec qualiTI test reports, server config datasheet, etc)
+ for file in `find . -name *.html`; do
+ cp ${file} ${D}/${installdir}/ti-codecs-server
+ done
+
+ install -d ${D}${CODEC_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${CODEC_INSTALL_DIR_RECIPE}
}
+
+PACKAGES += "ti-codecs-omap3530-server"
+FILES_ti-codecs-omap3530-server = "${installdir}/ti-codecs-server/*"