summaryrefslogtreecommitdiff
path: root/recipes/ti/am-benchmarks_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/am-benchmarks_svn.bb')
-rw-r--r--recipes/ti/am-benchmarks_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/ti/am-benchmarks_svn.bb b/recipes/ti/am-benchmarks_svn.bb
new file mode 100644
index 0000000000..23e194683a
--- /dev/null
+++ b/recipes/ti/am-benchmarks_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "AM Benchmarks"
+HOMEPAGE = "https://gforge.ti.com/gf/project/am_benchmarks/"
+LICENSE = "BSD"
+SECTION = "system"
+PRIORITY = "optional"
+
+SRCREV = "27"
+PV = "1.0"
+PR = "r1+svnr${SRCPV}"
+
+INSANE_SKIP_${PN} = "True"
+
+SRC_URI = "svn://gforge.ti.com/svn/am_benchmarks/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+S = "${WORKDIR}/trunk"
+
+do_compile() {
+ # don't build debug version
+ touch debug
+ export CROSS_COMPILE=${TARGET_PREFIX}
+ make release
+}
+
+do_install() {
+ make DESTDIR=${D} install
+}