summaryrefslogtreecommitdiff
path: root/recipes/telepathy/telepathy-salut_0.3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/telepathy/telepathy-salut_0.3.4.bb')
-rw-r--r--recipes/telepathy/telepathy-salut_0.3.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/telepathy/telepathy-salut_0.3.4.bb b/recipes/telepathy/telepathy-salut_0.3.4.bb
new file mode 100644
index 0000000000..c8b9edaee1
--- /dev/null
+++ b/recipes/telepathy/telepathy-salut_0.3.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Salut: Link-local XMPP connection manager for the Telepathy framework"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "telepathy-glib avahi telepathy-gabble"
+LICENSE = "LGPL"
+
+#salut.manager changes every release, don't copy it over blindly!
+SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz \
+ file://keep-manager-file.diff;patch=1 \
+ file://salut.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/salut.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"