summaryrefslogtreecommitdiff
path: root/recipes/serial-utils/pty-forward-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/serial-utils/pty-forward-native.bb')
-rw-r--r--recipes/serial-utils/pty-forward-native.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes/serial-utils/pty-forward-native.bb b/recipes/serial-utils/pty-forward-native.bb
index c613276645..0cc21e1fc6 100644
--- a/recipes/serial-utils/pty-forward-native.bb
+++ b/recipes/serial-utils/pty-forward-native.bb
@@ -2,26 +2,17 @@ DESCRIPTION = "Receive a forwarded serial from serial-forward and provide a PTY"
AUTHOR = "Holger 'Zecke' Freyther"
LICENSE = "GPL"
SECTION = "console/network"
-PV = "1.0.1+gitr${SRCREV}"
+PV = "1.1+gitr${SRCREV}"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git"
S = "${WORKDIR}/git/tools/serial_forward"
-inherit native
-
-do_compile() {
- cd ${S}
- oe_runmake
-}
-
-do_stage() {
- :
-}
+inherit autotools native
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+ install -m 0755 ${S}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
}
addtask deploy before do_package after do_install