summaryrefslogtreecommitdiff
path: root/recipes/sdlperl/sdl-perl_1.20.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sdlperl/sdl-perl_1.20.3.bb')
-rw-r--r--recipes/sdlperl/sdl-perl_1.20.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/sdlperl/sdl-perl_1.20.3.bb b/recipes/sdlperl/sdl-perl_1.20.3.bb
new file mode 100644
index 0000000000..6820fa05ce
--- /dev/null
+++ b/recipes/sdlperl/sdl-perl_1.20.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Perl bindings for SDL"
+SECTION = "libs"
+HOMEPAGE = "http://sdl.perl.org/"
+LICENSE = "GPL"
+DEPENDS = "perl virtual/libsdl libsdl-image libsdl-gfx libsdl-ttf libsdl-mixer libsdl-net smpeg"
+PR = "r1"
+
+SRC_URI = "http://bloodgate.com/perl/sdl/pub/SDL_perl-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_perl-${PV}"
+
+inherit cpan
+
+do_configure_prepend() {
+ # Search staging area for includes
+ sed -i -e 's:/usr/\(local/\)\{0,1\}include:${STAGING_INCDIR}:g' Makefile.linux
+ # smpeg.h isn't in a subdirectry
+ sed -i -e 's:#include <smpeg/smpeg.h>:#include <smpeg.h>:g' SDL_perl.xs
+}