summaryrefslogtreecommitdiff
path: root/recipes/realpath/realpath_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/realpath/realpath_1.10.bb')
-rw-r--r--recipes/realpath/realpath_1.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/realpath/realpath_1.10.bb b/recipes/realpath/realpath_1.10.bb
new file mode 100644
index 0000000000..4833740907
--- /dev/null
+++ b/recipes/realpath/realpath_1.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Return the canonicalized absolute pathname"
+SECTION = "utility"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
+ file://makefile.patch;patch=1"
+
+SRC_URI[realpath.md5sum] = "1f2b2bceaacadf79162a9cbb5956c3b6"
+SRC_URI[realpath.sha256sum] = "72199f9c11d1f9a36b3b9693988b558a167def6b88fa146ea6a7f7223f96c535"
+
+CFLAGS += "-DVERSION=${PV}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -p -m 0755 ${S}/realpath ${D}${bindir}
+}