summaryrefslogtreecommitdiff
path: root/recipes/ppp-dsl/ppp-dsl_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ppp-dsl/ppp-dsl_0.1.bb')
-rw-r--r--recipes/ppp-dsl/ppp-dsl_0.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/ppp-dsl/ppp-dsl_0.1.bb b/recipes/ppp-dsl/ppp-dsl_0.1.bb
new file mode 100644
index 0000000000..8d63e8fc47
--- /dev/null
+++ b/recipes/ppp-dsl/ppp-dsl_0.1.bb
@@ -0,0 +1,30 @@
+SECTION = "console/network"
+DESCRIPTION = "Enables PPP dial-in through a DSL connection"
+LICENSE = "PD"
+DEPENDS = "ppp rp-pppoe"
+RDEPENDS = "ppp rp-pppoe"
+RRECOMMENDS = "kernel-module-ppp-async kernel-module-ppp-generic kernel-module-slhc"
+PR = "r5"
+
+SRC_URI = "file://dsl-provider \
+ file://ppp_on_boot.dsl"
+
+do_install() {
+ install -d ${D}${sysconfdir}/ppp/peers
+ install -m 0644 ${WORKDIR}/dsl-provider ${D}${sysconfdir}/ppp/peers/
+ install -m 0755 ${WORKDIR}/ppp_on_boot.dsl ${D}${sysconfdir}/ppp/
+}
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ if ! test -e ${sysconfdir}/ppp/ppp_on_boot; then
+ ln -s ppp_on_boot.dsl ${sysconfdir}/ppp/ppp_on_boot
+ fi
+fi
+}
+
+PACKAGE_ARCH = "all"
+
+CONFFILES_${PN} = "${sysconfdir}/ppp/peers/dsl-provider"