summaryrefslogtreecommitdiff
path: root/recipes/powervr-drivers/omap3-sgx-modules_1.2.12.838.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/powervr-drivers/omap3-sgx-modules_1.2.12.838.bb')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.2.12.838.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.2.12.838.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.2.12.838.bb
new file mode 100644
index 0000000000..6f57e532f0
--- /dev/null
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.2.12.838.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://dominion.thruhere.net/koen/OE/omap3-sgx-modules-${PV}.tar.bz2 \
+"
+
+MAKE_TARGETS = "BUILD=debug"
+
+do_compile_prepend() {
+ cd ${S}/eurasiacon/build/linux/omap3430_linux/kbuild/
+}
+
+do_install() {
+ cd ${S}/eurasiacon/build/linux/omap3430_linux/kbuild/
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
+ cp ${WORKDIR}/${PN}-${PV}/eurasiacon/binary_omap3430_linux_debug/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
+}