summaryrefslogtreecommitdiff
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 2508719736..13e44556be 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r29"
+PR = "r30"
# Major part of version
PVM = "5.8"
@@ -141,12 +141,11 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR_HOST}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
+ install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR_HOST}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration