summaryrefslogtreecommitdiff
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 35fcc83ccc..02ad7bf376 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -141,12 +141,11 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
+ install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration