summaryrefslogtreecommitdiff
path: root/recipes/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl-native_5.8.8.bb')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index bde7638137..ba05406eb0 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -66,10 +66,10 @@ do_stage_append() {
# We need a hostperl link for building perl
ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
# Store native config in non-versioned directory
- install -d ${STAGING_DIR_HOST}/perl \
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl \
${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE \
${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
- install config.sh ${STAGING_DIR_HOST}/perl
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl
# target configuration
install lib/Config.pm ${STAGING_LIBDIR_NATIVE}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/
@@ -88,7 +88,7 @@ do_stage_append() {
}
do_stage_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR_HOST}/perl/config.sh; do
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR}/${HOST_SYS}/perl/config.sh; do
perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
done
}