summaryrefslogtreecommitdiff
path: root/recipes/opkg/opkg-native_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opkg/opkg-native_svn.bb')
-rw-r--r--recipes/opkg/opkg-native_svn.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/opkg/opkg-native_svn.bb b/recipes/opkg/opkg-native_svn.bb
new file mode 100644
index 0000000000..82c74e0b86
--- /dev/null
+++ b/recipes/opkg/opkg-native_svn.bb
@@ -0,0 +1,16 @@
+require opkg.inc
+
+DEPENDS = "curl-native"
+PR = "r3"
+
+target_libdir := "${libdir}"
+
+inherit native
+
+# The nogpg version isn't getting much love and has an unused variable which trips up -Werror
+do_configure_prepend() {
+ sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
+}
+
+
+EXTRA_OECONF += "--with-opkglibdir=${target_libdir} --disable-gpg"