summaryrefslogtreecommitdiff
path: root/recipes/opentom/ttimgextract.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opentom/ttimgextract.bb')
-rw-r--r--recipes/opentom/ttimgextract.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/opentom/ttimgextract.bb b/recipes/opentom/ttimgextract.bb
new file mode 100644
index 0000000000..02d2e1515d
--- /dev/null
+++ b/recipes/opentom/ttimgextract.bb
@@ -0,0 +1,17 @@
+LICENSE = "None"
+DESCRIPTION = "A tool to extract the ttsystem images into their components."
+
+SRC_URI = "svn://svn.opentom.org/opentom/trunk/;module=ttimgextract;proto=http"
+
+PV = "0.0+svn${SRCDATE}"
+S = "${WORKDIR}/${PN}"
+
+
+do_compile() {
+ ${CC} -o ttimgextract ttimgextract.c -DPATH_MAX=4096 ${TARGET_CC_ARCH}
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/ttimgextract ${D}${bindir}/
+}