summaryrefslogtreecommitdiff
path: root/recipes/openssh/openssh_3.8p1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openssh/openssh_3.8p1.bb')
-rw-r--r--recipes/openssh/openssh_3.8p1.bb89
1 files changed, 0 insertions, 89 deletions
diff --git a/recipes/openssh/openssh_3.8p1.bb b/recipes/openssh/openssh_3.8p1.bb
deleted file mode 100644
index fe5a623365..0000000000
--- a/recipes/openssh/openssh_3.8p1.bb
+++ /dev/null
@@ -1,89 +0,0 @@
-DEPENDS = "zlib openssl"
-SECTION = "console/network"
-DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
-Ssh (Secure Shell) is a program for logging into a remote machine \
-and for executing commands on a remote machine. \
-It provides secure encrypted communications between two untrusted \
-hosts over an insecure network. X11 connections and arbitrary TCP/IP \
-ports can also be forwarded over the secure channel. \
-It is intended as a replacement for rlogin, rsh and rcp, and can be \
-used to provide applications with a secure communication channel."
-HOMEPAGE = "http://www.openssh.org/"
-LICENSE = "BSD"
-PR ="r3"
-
-SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
- file://configure.patch \
- file://scp-nossl.patch \
- file://ssh_config \
- file://sshd_config \
- file://init"
-
-inherit autotools
-
-export ASKPASS_PROGRAM = "${bindir}/ssh-askpass"
-export LD = "${CC}"
-CFLAGS_prepend = "-I${S} "
-CFLAGS_append = " -D__FILE_OFFSET_BITS=64"
-LDFLAGS_prepend = "-L${S} -L${S}/openbsd-compat "
-EXTRA_OECONF = "--disable-suid-ssh --with-ssl=${STAGING_LIBDIR}/ssl \
- --with-rand-helper=no --without-pam \
- --without-zlib-version-check \
- --with-privsep-path=/var/run/sshd \
- --sysconfdir=${sysconfdir}/ssh"
-
-EXTRA_OEMAKE = "'STRIP_OPT='"
-
-do_configure_prepend () {
- if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
- cp aclocal.m4 acinclude.m4
- fi
-}
-
-do_compile_append () {
- install -m 0644 ${WORKDIR}/sshd_config ${S}/
- install -m 0644 ${WORKDIR}/ssh_config ${S}/
-}
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
-}
-
-PACKAGES =+ " openssh-scp openssh-ssh openssh-sshd openssh-sftp openssh-misc"
-FILES_openssh-scp = "${bindir}/scp"
-FILES_openssh-ssh = "${bindir}/ssh ${bindir}/slogin /${sysconfdir}/ssh/ssh_config"
-FILES_openssh-sshd = "${sbindir}/sshd /${sysconfdir}/init.d/sshd ${bindir}/ssh-keygen"
-FILES_openssh-sshd += " /${sysconfdir}/ssh/moduli /${sysconfdir}/ssh/sshd_config /var/run/sshd"
-FILES_openssh-sftp = "${bindir}/sftp ${libdir}exec/sftp-server"
-FILES_openssh-misc = "${bindir} ${libdir}exec/"
-RDEPENDS_openssh += " openssh-scp openssh-ssh openssh-sshd"
-DEPENDS_openssh-sshd += " update-rc.d"
-RDEPENDS_openssh-sshd += " update-rc.d"
-
-pkg_postinst_openssh-sshd() {
-if test "x$D" != "x"; then
- exit 1
-else
- addgroup sshd
- adduser --system --home /var/run/sshd --no-create-home --disabled-password --ingroup sshd -s /bin/false sshd
- update-rc.d sshd defaults
-fi
-}
-
-pkg_postrm_openssh-sshd() {
-if test "x$D" != "x"; then
- exit 1
-else
- ${sysconfdir}/init.d/sshd stop
- deluser sshd
- delgroup sshd
- update-rc.d -f sshd remove
-fi
-}
-
-CONFFILES_openssh-sshd = "${sysconfdir}/ssh/sshd_config"
-CONFFILES_openssh-ssh = "${sysconfdir}/ssh/ssh_config"
-
-SRC_URI[md5sum] = "7861a4c0841ab69a6eec5c747daff6fb"
-SRC_URI[sha256sum] = "4304eebd70fb7e8a565fc8bb32930abb0682b274db9fca4b50f47677bf9966b6"