summaryrefslogtreecommitdiff
path: root/recipes/obsolete/openmoko-projects/om-settings_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/openmoko-projects/om-settings_svn.bb')
-rw-r--r--recipes/obsolete/openmoko-projects/om-settings_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/obsolete/openmoko-projects/om-settings_svn.bb b/recipes/obsolete/openmoko-projects/om-settings_svn.bb
new file mode 100644
index 0000000000..bf2b5410e8
--- /dev/null
+++ b/recipes/obsolete/openmoko-projects/om-settings_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Exposure all devices on neo1973"
+DEPENDS = "python-etk python-edbus"
+RDEPENDS_${PN} = "python-etk python-re python-codecs python-edbus python-pyxdg"
+SRCREV = "74"
+PV = "0.0.1+svnr${SRCPV}"
+PR = "r4"
+PE = "1"
+
+S = "${WORKDIR}/trunk"
+
+inherit setuptools
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/exposure;module=trunk;proto=http \
+ "
+
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${prefix}/share/* ${sysconfdir}/X11/Xsession.d/*"
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+if test "x$D" = "x"; then
+ killall exposure.py
+ sleep 1
+ exposure.py
+fi
+}