summaryrefslogtreecommitdiff
path: root/recipes/llvm/llvm2.7_2.6+svnr20091007.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/llvm/llvm2.7_2.6+svnr20091007.bb')
-rw-r--r--recipes/llvm/llvm2.7_2.6+svnr20091007.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/llvm/llvm2.7_2.6+svnr20091007.bb b/recipes/llvm/llvm2.7_2.6+svnr20091007.bb
new file mode 100644
index 0000000000..142e15ea4f
--- /dev/null
+++ b/recipes/llvm/llvm2.7_2.6+svnr20091007.bb
@@ -0,0 +1,25 @@
+require llvm.inc
+
+SRCREV = "83459"
+
+PV = "2.6+svnr${SRCPV}"
+
+PR = "r0"
+
+DEPENDS = "llvm-common llvm2.7-native"
+
+SRC_URI = "\
+ svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+ file://llvm-debugonly-zeroormore.patch;patch=1 \
+ file://BX_to_BLX.patch;patch=1 \
+ "
+
+EXTRA_OECMAKE += "\
+ -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
+ -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
+ "
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.7"