summaryrefslogtreecommitdiff
path: root/recipes/linux/linux_2.6.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux_2.6.32.bb')
-rw-r--r--recipes/linux/linux_2.6.32.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/linux/linux_2.6.32.bb b/recipes/linux/linux_2.6.32.bb
new file mode 100644
index 0000000000..99db01bf8b
--- /dev/null
+++ b/recipes/linux/linux_2.6.32.bb
@@ -0,0 +1,46 @@
+require linux.inc
+
+PR = "r1"
+
+S = "${WORKDIR}/linux-${PV}"
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_simone = "1"
+DEFAULT_PREFERENCE_akita = "-1"
+DEFAULT_PREFERENCE_c7x0 = "-1"
+DEFAULT_PREFERENCE_collie = "-1"
+DEFAULT_PREFERENCE_poodle = "-1"
+DEFAULT_PREFERENCE_spitz = "-1"
+DEFAULT_PREFERENCE_tosa = "-1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
+ file://defconfig"
+
+SRC_URI[kernel.md5sum] = "260551284ac224c3a43c4adac7df4879"
+SRC_URI[kernel.sha256sum] = "5099786d80b8407d98a619df00209c2353517f22d804fdd9533b362adcb4504e"
+
+# part of 2.6.24.7 patchset from Sim.One project
+# other patches needs work
+SRC_URI_append_simone = " \
+ file://ep93xx/edb9301-fix-machine-id.patch;patch=1 \
+ file://ep93xx/simone-board-def.patch;patch=1 \
+ file://ep93xx/ep93xx-regs.patch;patch=1 \
+ file://ep93xx/ep93xx-i2c.patch;patch=1 \
+ file://ep93xx/ep93xx-touchscreen.patch;patch=1 \
+ file://ep93xx/ep93xx-spi.patch;patch=1 \
+ file://ep93xx/ep93xx-cpuinfo.patch;patch=1 "
+
+# Zaurus family bootloader patches
+RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
+ZAURUSPATCHES = " ${RPSRC}/pxa-linking-bug-r1.patch;patch=1;status=unmergable;name=pxa-linking-bug-r1 "
+SRC_URI[pxa-linking-bug-r1.md5sum] = "1e2a99787260c3566033e7f41180e2c8"
+SRC_URI[pxa-linking-bug-r1.sha256sum] = "785d2680022325ad54c1593082dce902f5fee31dae4c1922ba43956b1dcfcd8b"
+
+# Machine specific patches
+SRC_URI_append_akita = "${ZAURUSPATCHES}"
+SRC_URI_append_c7x0 = "${ZAURUSPATCHES}"
+SRC_URI_append_collie = "${ZAURUSPATCHES}"
+SRC_URI_append_poodle = "${ZAURUSPATCHES}"
+SRC_URI_append_spitz = "${ZAURUSPATCHES}"
+SRC_URI_append_tosa = "${ZAURUSPATCHES}"