summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-kirkwood_2.6.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-kirkwood_2.6.31.bb')
-rw-r--r--recipes/linux/linux-kirkwood_2.6.31.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes/linux/linux-kirkwood_2.6.31.bb b/recipes/linux/linux-kirkwood_2.6.31.bb
index a81fe91dc7..f046feaadd 100644
--- a/recipes/linux/linux-kirkwood_2.6.31.bb
+++ b/recipes/linux/linux-kirkwood_2.6.31.bb
@@ -9,6 +9,8 @@ COMPATIBLE_MACHINE = "openrd-base"
require linux.inc
+FILESPATHPKG_prepend = "linux-2.6.31:"
+
# Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
PV = "2.6.31"
@@ -19,8 +21,15 @@ SRC_URI = "git://git.marvell.com/orion.git;protocol=git \
file://defconfig"
SRC_URI_append_openrd-base = " file://openrd-base-enable-pcie.patch;patch=1 \
- file://cpuidle-reenable-interrupts.patch;patch=1"
-
+ file://cpuidle-reenable-interrupts.patch;patch=1 \
+ file://0001-Squashfs-move-zlib-decompression-wrapper-code-into.patch;patch=1 \
+ file://0002-Squashfs-Factor-out-remaining-zlib-dependencies-int.patch;patch=1 \
+ file://0003-Squashfs-add-a-decompressor-framework.patch;patch=1 \
+ file://0004-Squashfs-add-decompressor-entries-for-lzma-and-lzo.patch;patch=1 \
+ file://0005-Squashfs-add-an-extra-parameter-to-the-decompressor.patch;patch=1 \
+ file://0006-Squashfs-add-LZMA-compression.patch;patch=1 \
+ file://0007-Squashfs-Make-unlzma-available-to-non-initramfs-ini.patch;patch=1 \
+ "
# update machine types list for ARM architecture, only for machines that need it
do_arm_mach_types() {
if test ${MACHINE} == openrd-base; then