summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-h6300-omap1_2.6.14.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-h6300-omap1_2.6.14.3.bb')
-rw-r--r--recipes/linux/linux-h6300-omap1_2.6.14.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/linux/linux-h6300-omap1_2.6.14.3.bb b/recipes/linux/linux-h6300-omap1_2.6.14.3.bb
new file mode 100644
index 0000000000..7726bad494
--- /dev/null
+++ b/recipes/linux/linux-h6300-omap1_2.6.14.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Linux kernel for h6300 devices."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.14.tar.bz2 \
+ http://www.muru.com/linux/omap/patches/patch-2.6.14-omap2.bz2;patch=1 \
+ file://patch-linux-2614-omap2-to-2614_3-omap1-h6300;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.14"
+
+inherit kernel
+
+COMPATIBLE_MACHINE = "h6300"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ oe_runmake oldconfig
+}