summaryrefslogtreecommitdiff
path: root/recipes/libetpan/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libetpan/files')
-rw-r--r--recipes/libetpan/files/honor-oe-lflags.patch16
-rw-r--r--recipes/libetpan/files/libetpan-autoreconf.patch12
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/libetpan/files/honor-oe-lflags.patch b/recipes/libetpan/files/honor-oe-lflags.patch
new file mode 100644
index 0000000000..15a1535bfa
--- /dev/null
+++ b/recipes/libetpan/files/honor-oe-lflags.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- libetpan-0.46/configure.in~honor-oe-lflags
++++ libetpan-0.46/configure.in
+@@ -361,7 +361,7 @@
+ LDFLAGS="-$flag $LDFLAGS"
+ AC_TRY_LINK([], [pthread_create();],
+ [pthflag=yes; checkpthread=no],
+- [pthflag=no; LDFLAGS="$OLDCFLAGS"])
++ [pthflag=no; LDFLAGS="$OLDFLAGS"])
+ AC_MSG_RESULT($pthflag)
+ fi
+ done
diff --git a/recipes/libetpan/files/libetpan-autoreconf.patch b/recipes/libetpan/files/libetpan-autoreconf.patch
new file mode 100644
index 0000000000..d05967da31
--- /dev/null
+++ b/recipes/libetpan/files/libetpan-autoreconf.patch
@@ -0,0 +1,12 @@
+Index: libetpan-0.57/configure.ac
+===================================================================
+--- libetpan-0.57.orig/configure.ac 2008-10-08 19:54:20.000000000 +0000
++++ libetpan-0.57/configure.ac 2008-11-11 16:34:33.000000000 +0000
+@@ -106,6 +106,7 @@
+
+ # Check the C compiler.
+ AC_PROG_CC
++AC_PROG_CXX
+
+ # Compiler flags.
+ AC_ARG_ENABLE(debug, [ --enable-debug setup flags (gcc) for debugging (default=no)],