summaryrefslogtreecommitdiff
path: root/recipes/kexec-tools/kexec-tools-klibc-static_2.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/kexec-tools/kexec-tools-klibc-static_2.0.2.bb')
-rw-r--r--recipes/kexec-tools/kexec-tools-klibc-static_2.0.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/kexec-tools/kexec-tools-klibc-static_2.0.2.bb b/recipes/kexec-tools/kexec-tools-klibc-static_2.0.2.bb
new file mode 100644
index 0000000000..963548fe5f
--- /dev/null
+++ b/recipes/kexec-tools/kexec-tools-klibc-static_2.0.2.bb
@@ -0,0 +1,30 @@
+# the binaries are statically linked against klibc
+require kexec-tools_${PV}.inc
+
+PR = "r0"
+DEPENDS = "klibc"
+
+FILESPATHPKG =. "kexec-tools-${PV}:"
+
+SRC_URI += "file://headers.patch \
+ file://elf.patch \
+ file://errno.patch \
+ file://string.patch \
+ file://syscall.patch \
+ file://other.patch \
+ "
+
+S = "${WORKDIR}/kexec-tools-${PV}"
+
+EXTRA_OECONF = " --without-zlib"
+export CC=${TARGET_PREFIX}klcc
+
+# reset inherited OE flags to avoid e.g. ggdb3 and keep size small
+export CFLAGS=""
+export CPPFLAGS=""
+export LDFLAGS=""
+
+PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
+
+FILES_kexec-klibc-static = "${sbindir}/kexec"
+FILES_kdump-klibc-static = "${sbindir}/kdump"