summaryrefslogtreecommitdiff
path: root/recipes/kexec-tools/kexec-tools-2.0.1/kexec-tools-2-arm-add-uImage.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/kexec-tools/kexec-tools-2.0.1/kexec-tools-2-arm-add-uImage.patch')
-rw-r--r--recipes/kexec-tools/kexec-tools-2.0.1/kexec-tools-2-arm-add-uImage.patch271
1 files changed, 0 insertions, 271 deletions
diff --git a/recipes/kexec-tools/kexec-tools-2.0.1/kexec-tools-2-arm-add-uImage.patch b/recipes/kexec-tools/kexec-tools-2.0.1/kexec-tools-2-arm-add-uImage.patch
deleted file mode 100644
index 69a1588ba2..0000000000
--- a/recipes/kexec-tools/kexec-tools-2.0.1/kexec-tools-2-arm-add-uImage.patch
+++ /dev/null
@@ -1,271 +0,0 @@
-From 160f15aa3b87b6b7b16ccad99f5ce110cacb8256 Mon Sep 17 00:00:00 2001
-From: Marc Andre Tanner <mat at brain-dump.org>
-Date: Fri, 20 Nov 2009 15:07:42 +0100
-Subject: [PATCH 2/2] kexec-arm: add uImage support
-
-uImages are basically just zImages with a special header,
-we therefore just skip the header and let the normal zImage
-infrastructure do the actual work.
-
-Signed-off-by: Marc Andre Tanner <mat at brain-dump.org>
----
- kexec/arch/arm/Makefile | 2 +
- kexec/arch/arm/kexec-arm.c | 3 +
- kexec/arch/arm/kexec-arm.h | 4 +
- kexec/arch/arm/kexec-uImage-arm.c | 33 ++++++++
- kexec/arch/arm/kexec-uImage-arm.h | 161 +++++++++++++++++++++++++++++++++++++
- 5 files changed, 203 insertions(+), 0 deletions(-)
- create mode 100644 kexec/arch/arm/kexec-uImage-arm.c
- create mode 100644 kexec/arch/arm/kexec-uImage-arm.h
-
-diff --git a/kexec/arch/arm/Makefile b/kexec/arch/arm/Makefile
-index e05e4c7..806c4d9 100644
---- a/kexec/arch/arm/Makefile
-+++ b/kexec/arch/arm/Makefile
-@@ -3,8 +3,10 @@
- #
- arm_KEXEC_SRCS= kexec/arch/arm/kexec-elf-rel-arm.c
- arm_KEXEC_SRCS+= kexec/arch/arm/kexec-zImage-arm.c
-+arm_KEXEC_SRCS+= kexec/arch/arm/kexec-uImage-arm.c
- arm_KEXEC_SRCS+= kexec/arch/arm/kexec-arm.c
-
- dist += kexec/arch/arm/Makefile $(arm_KEXEC_SRCS) \
- kexec/arch/arm/kexec-arm.h \
-+ kexec/arch/arm/kexec-uImage-arm.h \
- kexec/arch/arm/include/arch/options.h
-diff --git a/kexec/arch/arm/kexec-arm.c b/kexec/arch/arm/kexec-arm.c
-index 2e50489..3fdf839 100644
---- a/kexec/arch/arm/kexec-arm.c
-+++ b/kexec/arch/arm/kexec-arm.c
-@@ -74,6 +74,9 @@ int get_memory_ranges(struct memory_range **range, int *ranges,
-
- /* Supported file types and callbacks */
- struct file_type file_type[] = {
-+ /* uImage is probed before zImage because the latter also accepts
-+ uncompressed images. */
-+ {"uImage", uImage_arm_probe, uImage_arm_load, zImage_arm_usage},
- {"zImage", zImage_arm_probe, zImage_arm_load, zImage_arm_usage},
- };
- int file_types = sizeof(file_type) / sizeof(file_type[0]);
-diff --git a/kexec/arch/arm/kexec-arm.h b/kexec/arch/arm/kexec-arm.h
-index bb41ce0..0d9a066 100644
---- a/kexec/arch/arm/kexec-arm.h
-+++ b/kexec/arch/arm/kexec-arm.h
-@@ -6,4 +6,8 @@ int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
- struct kexec_info *info);
- void zImage_arm_usage(void);
-
-+int uImage_arm_probe(const char *buf, off_t len);
-+int uImage_arm_load(int argc, char **argv, const char *buf, off_t len,
-+ struct kexec_info *info);
-+
- #endif /* KEXEC_ARM_H */
-diff --git a/kexec/arch/arm/kexec-uImage-arm.c b/kexec/arch/arm/kexec-uImage-arm.c
-new file mode 100644
-index 0000000..218148a
---- /dev/null
-+++ b/kexec/arch/arm/kexec-uImage-arm.c
-@@ -0,0 +1,33 @@
-+/*
-+ * uImage support added by Marc Andre Tanner <mat at brain-dump.org>
-+ */
-+#include <stdint.h>
-+#include <string.h>
-+#include <sys/types.h>
-+#include "../../kexec.h"
-+#include "kexec-arm.h"
-+#include "kexec-uImage-arm.h"
-+
-+int uImage_arm_probe(const char *buf, off_t len)
-+{
-+ struct image_header header;
-+
-+ if (len < sizeof(header))
-+ return -1;
-+
-+ memcpy(&header, buf, sizeof(header));
-+
-+ if (cpu_to_be32(header.ih_magic) != IH_MAGIC)
-+ return -1;
-+
-+ /* XXX: check CRC Checksum? */
-+
-+ return 0;
-+}
-+
-+int uImage_arm_load(int argc, char **argv, const char *buf, off_t len,
-+ struct kexec_info *info)
-+{
-+ return zImage_arm_load(argc, argv, buf + sizeof(struct image_header),
-+ len - sizeof(struct image_header), info);
-+}
-diff --git a/kexec/arch/arm/kexec-uImage-arm.h b/kexec/arch/arm/kexec-uImage-arm.h
-new file mode 100644
-index 0000000..b9079a4
---- /dev/null
-+++ b/kexec/arch/arm/kexec-uImage-arm.h
-@@ -0,0 +1,161 @@
-+/*
-+ * (C) Copyright 2000-2005
-+ * Wolfgang Denk, DENX Software Engineering, wd at denx.de.
-+ *
-+ * See file CREDITS for list of people who contributed to this
-+ * project.
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License as
-+ * published by the Free Software Foundation; either version 2 of
-+ * the License, or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
-+ * MA 02111-1307 USA
-+ *
-+ ********************************************************************
-+ * NOTE: This header file defines an interface to U-Boot. Including
-+ * this (unmodified) header file in another file is considered normal
-+ * use of U-Boot, and does *not* fall under the heading of "derived
-+ * work".
-+ ********************************************************************
-+ */
-+
-+#ifndef __IMAGE_H__
-+#define __IMAGE_H__
-+
-+/*
-+ * Operating System Codes
-+ */
-+#define IH_OS_INVALID 0 /* Invalid OS */
-+#define IH_OS_OPENBSD 1 /* OpenBSD */
-+#define IH_OS_NETBSD 2 /* NetBSD */
-+#define IH_OS_FREEBSD 3 /* FreeBSD */
-+#define IH_OS_4_4BSD 4 /* 4.4BSD */
-+#define IH_OS_LINUX 5 /* Linux */
-+#define IH_OS_SVR4 6 /* SVR4 */
-+#define IH_OS_ESIX 7 /* Esix */
-+#define IH_OS_SOLARIS 8 /* Solaris */
-+#define IH_OS_IRIX 9 /* Irix */
-+#define IH_OS_SCO 10 /* SCO */
-+#define IH_OS_DELL 11 /* Dell */
-+#define IH_OS_NCR 12 /* NCR */
-+#define IH_OS_LYNXOS 13 /* LynxOS */
-+#define IH_OS_VXWORKS 14 /* VxWorks */
-+#define IH_OS_PSOS 15 /* pSOS */
-+#define IH_OS_QNX 16 /* QNX */
-+#define IH_OS_U_BOOT 17 /* Firmware */
-+#define IH_OS_RTEMS 18 /* RTEMS */
-+#define IH_OS_ARTOS 19 /* ARTOS */
-+#define IH_OS_UNITY 20 /* Unity OS */
-+
-+/*
-+ * CPU Architecture Codes (supported by Linux)
-+ */
-+#define IH_CPU_INVALID 0 /* Invalid CPU */
-+#define IH_CPU_ALPHA 1 /* Alpha */
-+#define IH_CPU_ARM 2 /* ARM */
-+#define IH_CPU_I386 3 /* Intel x86 */
-+#define IH_CPU_IA64 4 /* IA64 */
-+#define IH_CPU_MIPS 5 /* MIPS */
-+#define IH_CPU_MIPS64 6 /* MIPS 64 Bit */
-+#define IH_CPU_PPC 7 /* PowerPC */
-+#define IH_CPU_S390 8 /* IBM S390 */
-+#define IH_CPU_SH 9 /* SuperH */
-+#define IH_CPU_SPARC 10 /* Sparc */
-+#define IH_CPU_SPARC64 11 /* Sparc 64 Bit */
-+#define IH_CPU_M68K 12 /* M68K */
-+#define IH_CPU_NIOS 13 /* Nios-32 */
-+#define IH_CPU_MICROBLAZE 14 /* MicroBlaze */
-+#define IH_CPU_NIOS2 15 /* Nios-II */
-+#define IH_CPU_BLACKFIN 16 /* Blackfin */
-+#define IH_CPU_AVR32 17 /* AVR32 */
-+
-+/*
-+ * Image Types
-+ *
-+ * "Standalone Programs" are directly runnable in the environment
-+ * provided by U-Boot; it is expected that (if they behave
-+ * well) you can continue to work in U-Boot after return from
-+ * the Standalone Program.
-+ * "OS Kernel Images" are usually images of some Embedded OS which
-+ * will take over control completely. Usually these programs
-+ * will install their own set of exception handlers, device
-+ * drivers, set up the MMU, etc. - this means, that you cannot
-+ * expect to re-enter U-Boot except by resetting the CPU.
-+ * "RAMDisk Images" are more or less just data blocks, and their
-+ * parameters (address, size) are passed to an OS kernel that is
-+ * being started.
-+ * "Multi-File Images" contain several images, typically an OS
-+ * (Linux) kernel image and one or more data images like
-+ * RAMDisks. This construct is useful for instance when you want
-+ * to boot over the network using BOOTP etc., where the boot
-+ * server provides just a single image file, but you want to get
-+ * for instance an OS kernel and a RAMDisk image.
-+ *
-+ * "Multi-File Images" start with a list of image sizes, each
-+ * image size (in bytes) specified by an "uint32_t" in network
-+ * byte order. This list is terminated by an "(uint32_t)0".
-+ * Immediately after the terminating 0 follow the images, one by
-+ * one, all aligned on "uint32_t" boundaries (size rounded up to
-+ * a multiple of 4 bytes - except for the last file).
-+ *
-+ * "Firmware Images" are binary images containing firmware (like
-+ * U-Boot or FPGA images) which usually will be programmed to
-+ * flash memory.
-+ *
-+ * "Script files" are command sequences that will be executed by
-+ * U-Boot's command interpreter; this feature is especially
-+ * useful when you configure U-Boot to use a real shell (hush)
-+ * as command interpreter (=> Shell Scripts).
-+ */
-+
-+#define IH_TYPE_INVALID 0 /* Invalid Image */
-+#define IH_TYPE_STANDALONE 1 /* Standalone Program */
-+#define IH_TYPE_KERNEL 2 /* OS Kernel Image */
-+#define IH_TYPE_RAMDISK 3 /* RAMDisk Image */
-+#define IH_TYPE_MULTI 4 /* Multi-File Image */
-+#define IH_TYPE_FIRMWARE 5 /* Firmware Image */
-+#define IH_TYPE_SCRIPT 6 /* Script file */
-+#define IH_TYPE_FILESYSTEM 7 /* Filesystem Image (any type) */
-+#define IH_TYPE_FLATDT 8 /* Binary Flat Device Tree Blob */
-+
-+/*
-+ * Compression Types
-+ */
-+#define IH_COMP_NONE 0 /* No Compression Used */
-+#define IH_COMP_GZIP 1 /* gzip Compression Used */
-+#define IH_COMP_BZIP2 2 /* bzip2 Compression Used */
-+#define IH_COMP_LZMA 3 /* lzma Compression Used */
-+
-+#define IH_MAGIC 0x27051956 /* Image Magic Number */
-+#define IH_NMLEN 32 /* Image Name Length */
-+
-+/*
-+ * all data in network byte order (aka natural aka bigendian)
-+ */
-+
-+typedef struct image_header {
-+ uint32_t ih_magic; /* Image Header Magic Number */
-+ uint32_t ih_hcrc; /* Image Header CRC Checksum */
-+ uint32_t ih_time; /* Image Creation Timestamp */
-+ uint32_t ih_size; /* Image Data Size */
-+ uint32_t ih_load; /* Data Load Address */
-+ uint32_t ih_ep; /* Entry Point Address */
-+ uint32_t ih_dcrc; /* Image Data CRC Checksum */
-+ uint8_t ih_os; /* Operating System */
-+ uint8_t ih_arch; /* CPU architecture */
-+ uint8_t ih_type; /* Image Type */
-+ uint8_t ih_comp; /* Compression Type */
-+ uint8_t ih_name[IH_NMLEN]; /* Image Name */
-+} image_header_t;
-+
-+
-+#endif /* __IMAGE_H__ */
---
-1.6.4.4
-