summaryrefslogtreecommitdiff
path: root/recipes/gpe-login/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-login/files')
-rw-r--r--recipes/gpe-login/files/brightness-adjust-keyluanchrc.patch10
-rw-r--r--recipes/gpe-login/files/c-locale.patch11
-rw-r--r--recipes/gpe-login/files/chvt-keylaunch.patch12
-rw-r--r--recipes/gpe-login/files/gpe-xcalibrate-rises-from-dead.patch10
-rw-r--r--recipes/gpe-login/files/lock-on-supend.patch17
-rw-r--r--recipes/gpe-login/files/removeblue-fontsize8.patch14
-rw-r--r--recipes/gpe-login/files/size-autolock-properly.patch28
-rw-r--r--recipes/gpe-login/files/use-xtscal.patch11
8 files changed, 113 insertions, 0 deletions
diff --git a/recipes/gpe-login/files/brightness-adjust-keyluanchrc.patch b/recipes/gpe-login/files/brightness-adjust-keyluanchrc.patch
new file mode 100644
index 0000000000..cfc73f4d56
--- /dev/null
+++ b/recipes/gpe-login/files/brightness-adjust-keyluanchrc.patch
@@ -0,0 +1,10 @@
+--- gpe-login-0.88/gpe-login.keylaunchrc.orig 2007-06-05 00:50:27.000000000 +0000
++++ gpe-login-0.88/gpe-login.keylaunchrc 2007-06-05 00:52:03.000000000 +0000
+@@ -7,3 +7,7 @@
+ key=...*Right:-:~chvt 3
+ key=...*Escape:-:~/etc/init.d/gpe-dm stop
+
++# Brightness control
++key=...*3:-:~display-brightness.sh down
++key=...*4:-:~display-brightness.sh up
++
diff --git a/recipes/gpe-login/files/c-locale.patch b/recipes/gpe-login/files/c-locale.patch
new file mode 100644
index 0000000000..109825b53b
--- /dev/null
+++ b/recipes/gpe-login/files/c-locale.patch
@@ -0,0 +1,11 @@
+--- a/gpe-login.c.org 2007-11-29 16:11:53.000000000 +0200
++++ a/gpe-login.c 2008-01-02 20:13:27.000000000 +0200
+@@ -1180,7 +1180,7 @@
+ language_menu = gtk_option_menu_new ();
+
+ c_locale = g_malloc (sizeof (locale_item_t));
+- c_locale->name = "English";
++ c_locale->name = "English(C locale)";
+ c_locale->locale = "C";
+ locale_system_list = g_slist_append (NULL, c_locale);
+
diff --git a/recipes/gpe-login/files/chvt-keylaunch.patch b/recipes/gpe-login/files/chvt-keylaunch.patch
new file mode 100644
index 0000000000..798c059ccc
--- /dev/null
+++ b/recipes/gpe-login/files/chvt-keylaunch.patch
@@ -0,0 +1,12 @@
+--- /tmp/gpe-login.keylaunchrc 2006-05-29 23:46:42.806081576 +0200
++++ gpe-login-0.87/gpe-login.keylaunchrc 2006-05-29 23:48:18.476537456 +0200
+@@ -1,3 +1,9 @@
+ key=????XF86AudioRecord:xcalibrate:/usr/bin/gpe-xcalibrate.sh
+ key=????XF86PowerDown:-:/usr/bin/apm --suspend
+ key=????Held XF86PowerDown:-:bl toggle
++
++# VT changing
++key=...*Left:-:~chvt 1
++key=...*Right:-:~chvt 3
++key=...*Escape:-:~/etc/init.d/gpe-dm stop
++
diff --git a/recipes/gpe-login/files/gpe-xcalibrate-rises-from-dead.patch b/recipes/gpe-login/files/gpe-xcalibrate-rises-from-dead.patch
new file mode 100644
index 0000000000..d1745f0897
--- /dev/null
+++ b/recipes/gpe-login/files/gpe-xcalibrate-rises-from-dead.patch
@@ -0,0 +1,10 @@
+upstream: http://bugs.linuxtogo.org/show_bug.cgi?id=124
+
+diff -r 976c01632fea gpe-login.keylaunchrc
+--- a/gpe-login.keylaunchrc Sun Nov 25 22:39:23 2007 +0200
++++ b/gpe-login.keylaunchrc Mon Nov 26 01:12:14 2007 +0200
+@@ -1,3 +1,3 @@ key=????XF86AudioRecord:xcalibrate:/usr/
+-key=????XF86AudioRecord:xcalibrate:/usr/bin/gpe-xcalibrate.sh
++key=????XF86AudioRecord:xcalibrate:/usr/bin/xtscal
+ key=????XF86PowerDown:-:/usr/bin/apm --suspend
+ key=????Held XF86PowerDown:-:bl toggle
diff --git a/recipes/gpe-login/files/lock-on-supend.patch b/recipes/gpe-login/files/lock-on-supend.patch
new file mode 100644
index 0000000000..0b00a75ead
--- /dev/null
+++ b/recipes/gpe-login/files/lock-on-supend.patch
@@ -0,0 +1,17 @@
+upstream: http://bugs.linuxtogo.org/show_bug.cgi?id=125
+status: accepted in 0.91
+
+Lock screen when device goes to suspend, not after some time has passed
+since resume and they stole your data from the unprotected screen.
+
+--- gpe-login-0.90/Makefile.am.org 2007-04-02 15:46:52.000000000 +0300
++++ gpe-login-0.90/Makefile.am 2007-11-24 22:41:24.000000000 +0200
+@@ -17,7 +17,7 @@
+ x11_SCRIPTS = gpe-login.setup X11/gpe-login.pre-session
+ x11_DATA = gpe-login.keylaunchrc X11/gpe-login.gtkrc
+
+-apmdir = $(sysconfdir)/apm/resume.d
++apmdir = $(sysconfdir)/apm/suspend.d
+ apm_SCRIPTS = gpe-login.suspend
+
+ xsessiondir = $(sysconfdir)/X11/Xsession.d
diff --git a/recipes/gpe-login/files/removeblue-fontsize8.patch b/recipes/gpe-login/files/removeblue-fontsize8.patch
new file mode 100644
index 0000000000..d9db311a2c
--- /dev/null
+++ b/recipes/gpe-login/files/removeblue-fontsize8.patch
@@ -0,0 +1,14 @@
+--- /tmp/gpe-login.gtkrc 2005-11-08 17:15:50.363302568 +0100
++++ gpe-login-0.83/X11/gpe-login.gtkrc 2005-11-08 17:16:22.659392816 +0100
+@@ -1,9 +1,2 @@
+-gtk-font-name = "Sans 8"
+-include "/usr/share/themes/Angelistic/gtk-2.0/gtkrc"
+-
+-style "default"
+-{
+- bg[NORMAL] = "#90d8ff"
+-}
+-
+-widget "*" style "default"
++gtk-font-name = "Sans 8"
++include "/usr/share/themes/Clearlooks/gtk-2.0/gtkrc"
diff --git a/recipes/gpe-login/files/size-autolock-properly.patch b/recipes/gpe-login/files/size-autolock-properly.patch
new file mode 100644
index 0000000000..cf2978f34d
--- /dev/null
+++ b/recipes/gpe-login/files/size-autolock-properly.patch
@@ -0,0 +1,28 @@
+upstream: http://bugs.linuxtogo.org/show_bug.cgi?id=152
+
+# HG changeset patch
+# User "Paul Sokolovsky <pfalcon@users.sourceforge.net>"
+# Date 1196345352 -7200
+# Node ID ebe625e21708cb9257201a4dd6e536b99f1f0220
+# Parent 976c01632feacbcce2058a061a0b1f6faed2275a
+When configuring autolock window, make sure to set not only the minimal
+("requested") size, but also the actual one. This fixes issue that after
+autolock screen have been shown in landscape mode, it no longer fits the
+screen in portrait mode.
+
+Also, gtk_widget_set_usize() marked as deprecated, replace with
+gtk_widget_set_size_request().
+
+diff -r 976c01632fea -r ebe625e21708 gpe-login.c
+--- a/gpe-login.c Sun Nov 25 22:39:23 2007 +0200
++++ b/gpe-login.c Thu Nov 29 16:09:12 2007 +0200
+@@ -558,7 +558,8 @@ filter (GdkXEvent *xevp, GdkEvent *ev, g
+ {
+ spawn_xkbd ();
+ gtk_label_set_markup (GTK_LABEL (label_result), "");
+- gtk_widget_set_usize (window, gdk_screen_width (), gdk_screen_height ());
++ gtk_widget_set_size_request (window, gdk_screen_width (), gdk_screen_height ());
++ gtk_window_resize (window, gdk_screen_width (), gdk_screen_height ());
+ gtk_widget_show_all (window);
+ if (ownerinfo)
+ {
diff --git a/recipes/gpe-login/files/use-xtscal.patch b/recipes/gpe-login/files/use-xtscal.patch
new file mode 100644
index 0000000000..dca1163505
--- /dev/null
+++ b/recipes/gpe-login/files/use-xtscal.patch
@@ -0,0 +1,11 @@
+--- /tmp/gpe-login.c 2007-04-01 11:40:29.000000000 +0200
++++ gpe-login-0.88/gpe-login.c 2007-04-01 11:40:58.205251000 +0200
+@@ -59,7 +59,7 @@
+ #define GPE_OWNERINFO_DONTSHOW_FILE "/etc/gpe/gpe-ownerinfo.dontshow"
+ /* Number of milliseconds to hold the stylus down before recalibration is called */
+ #define RECALIBRATION_TIMEOUT 5000
+-#define XTSCAL_PATH "/usr/bin/gpe-xcalibrate.sh"
++#define XTSCAL_PATH "/usr/bin/xtscal"
+ #ifndef DEBUG
+ #define DEBUG 0
+ #endif