summaryrefslogtreecommitdiff
path: root/recipes/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-panel_2.26.0.bb24
-rw-r--r--recipes/gnome/gnome-python-desktop_2.26.0.bb28
-rw-r--r--recipes/gnome/libgweather_2.26.0.bb25
3 files changed, 77 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-panel_2.26.0.bb b/recipes/gnome/gnome-panel_2.26.0.bb
new file mode 100644
index 0000000000..b2d615a750
--- /dev/null
+++ b/recipes/gnome/gnome-panel_2.26.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+EXTRA_OECONF = "--disable-scrollkeeper \
+ --disable-eds \
+ "
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/gnome/gnome-python-desktop_2.26.0.bb b/recipes/gnome/gnome-python-desktop_2.26.0.bb
new file mode 100644
index 0000000000..0ddc05e8e0
--- /dev/null
+++ b/recipes/gnome/gnome-python-desktop_2.26.0.bb
@@ -0,0 +1,28 @@
+LICENSE = "GPL/LGPL"
+DEPENDS = "librsvg libwnck totem-pl-parser libgtop gnome-panel gnome-desktop eds-dbus python-pygtk gnome-python libgnomeprint libgnomeprintui"
+
+PR = "r4"
+
+inherit gnome distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes\":g \
+ ${S}/configure.ac
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"
diff --git a/recipes/gnome/libgweather_2.26.0.bb b/recipes/gnome/libgweather_2.26.0.bb
new file mode 100644
index 0000000000..f36dbbdec7
--- /dev/null
+++ b/recipes/gnome/libgweather_2.26.0.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome libsoup-2.4 gtk+"
+
+inherit gnome
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+do_configure_prepend() {
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_stage() {
+ autotools_stage_all
+}