summaryrefslogtreecommitdiff
path: root/recipes/gnome/gnome-panel_2.26.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-panel_2.26.0.bb')
-rw-r--r--recipes/gnome/gnome-panel_2.26.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/gnome/gnome-panel_2.26.0.bb b/recipes/gnome/gnome-panel_2.26.0.bb
index b2d615a750..c744a44af7 100644
--- a/recipes/gnome/gnome-panel_2.26.0.bb
+++ b/recipes/gnome/gnome-panel_2.26.0.bb
@@ -1,8 +1,10 @@
LICENSE = "GPL"
-DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+DEPENDS = "gconf librsvg libgweather startup-notification libwnck orbit2 gtk+ libbonoboui libglade libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
inherit gnome pkgconfig
+SRC_URI += "file://idl-sysroot.patch;patch=1"
+
do_configure_prepend() {
sed -i -e s:help:: ${S}/Makefile.am
}
@@ -14,7 +16,8 @@ FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
FILES_${PN} =+ "${datadir}/gnome* \
${datadir}/icons"
-EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+export SYSROOT = "${STAGING_DIR_HOST}"
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2 SYSROOT=${SYSROOT}"
EXTRA_OECONF = "--disable-scrollkeeper \
--disable-eds \
"