summaryrefslogtreecommitdiff
path: root/recipes/gnome/gconf_2.26.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gconf_2.26.2.bb')
-rw-r--r--recipes/gnome/gconf_2.26.2.bb46
1 files changed, 14 insertions, 32 deletions
diff --git a/recipes/gnome/gconf_2.26.2.bb b/recipes/gnome/gconf_2.26.2.bb
index dcd0e621ef..dee0616c2a 100644
--- a/recipes/gnome/gconf_2.26.2.bb
+++ b/recipes/gnome/gconf_2.26.2.bb
@@ -3,49 +3,31 @@ SECTION = "x11/gnome"
LICENSE = "LGPL"
DEPENDS = "orbit2 glib-2.0 libxml2 policykit"
ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/GConf-${PV}"
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.26/GConf-${PV}.tar.bz2 \
- file://org.gnome.GConf.service \
- file://org.gnome.GConf.Defaults.service \
- "
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.26/GConf-${PV}.tar.bz2"
EXTRA_OECONF = "--disable-gtk-doc POLKIT_POLICY_FILE_VALIDATE=true"
-HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
-inherit autotools pkgconfig gettext
+inherit autotools_stage pkgconfig gettext
-do_compile() {
- oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
-}
-
-do_stage() {
- oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/gconf/2/gconf/
- ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
- install -m 0644 gconf-2.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
-}
+EXTRA_OEMAKE = 'ORBIT_IDL="${ORBIT_IDL_SRC}"'
-do_install() {
- oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+do_install_append() {
+ # this directory need to be created to avoid an Error 256 at gdm launch
+ install -d ${D}${sysconfdir}/gconf/gconf.xml.system
- install -d ${D}/${datadir}/dbus-1/services/
- install -m 0644 ${WORKDIR}/org.gnome.GConf.service ${D}/${datadir}/dbus-1/services/
-
- install -d ${D}/${datadir}/dbus-1/system-services/
- install -m 0644 ${WORKDIR}/org.gnome.GConf.Defaults.service ${D}/${datadir}/dbus-1/system-services/
-
- # this directory need to be created to avoid an Error 256 at gdm launch
- install -d ${D}/${sysconfdir}/gconf/gconf.xml.system
+ # this stuff is unusable
+ rm ${D}${libdir}/GConf/*/*.*a
}
FILES_${PN} += "${libdir}/GConf/* \
- ${datadir}/dbus-1/services \
- ${datadir}/dbus-1/system-services \
- "
+ ${datadir}/PolicyKit/policy/*.policy \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/dbus-1/system-services/*.service \
+"
FILES_${PN}-dbg += "${libdir}/*/*/.debug"
-FILES_${PN}-dev += "${libdir}/GConf/2/*.la ${datadir}/sgml/gconf/gconf-1.0.dtd"
-
+FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"