summaryrefslogtreecommitdiff
path: root/recipes/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-3.3.4.inc2
-rw-r--r--recipes/gcc/gcc-3.4.3.inc2
-rw-r--r--recipes/gcc/gcc-3.4.4.inc2
-rw-r--r--recipes/gcc/gcc-4.1.0.inc2
-rw-r--r--recipes/gcc/gcc-4.1.1.inc2
-rw-r--r--recipes/gcc/gcc-4.1.2.inc2
-rw-r--r--recipes/gcc/gcc-4.2.2.inc2
-rw-r--r--recipes/gcc/gcc-4.2.3.inc2
-rw-r--r--recipes/gcc/gcc-4.3.1.inc2
-rw-r--r--recipes/gcc/gcc-4.3.2.inc2
-rw-r--r--recipes/gcc/gcc-4.4.0.inc2
-rw-r--r--recipes/gcc/gcc-canadian-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_3.3.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_3.4.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_3.4.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.0.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.4.0.bb2
-rw-r--r--recipes/gcc/gcc-cross_3.3.4.bb2
-rw-r--r--recipes/gcc/gcc-cross_3.4.3.bb2
-rw-r--r--recipes/gcc/gcc-cross_3.4.4.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.1.0.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.1.1.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.1.2.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.2.2.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.2.3.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.4.0.bb2
-rw-r--r--recipes/gcc/gcc-native_3.4.4.bb2
-rw-r--r--recipes/gcc/gcc-package-sdk.inc5
-rw-r--r--recipes/gcc/gcc_3.3.4.bb2
-rw-r--r--recipes/gcc/gcc_3.4.3.bb2
-rw-r--r--recipes/gcc/gcc_3.4.4.bb2
-rw-r--r--recipes/gcc/gcc_4.1.0.bb2
-rw-r--r--recipes/gcc/gcc_4.1.1.bb2
-rw-r--r--recipes/gcc/gcc_4.1.2.bb2
-rw-r--r--recipes/gcc/gcc_4.2.2.bb2
-rw-r--r--recipes/gcc/gcc_4.2.3.bb2
-rw-r--r--recipes/gcc/gcc_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc_4.4.0.bb2
49 files changed, 61 insertions, 40 deletions
diff --git a/recipes/gcc/gcc-3.3.4.inc b/recipes/gcc/gcc-3.3.4.inc
index eec46d556d..635e617a78 100644
--- a/recipes/gcc/gcc-3.3.4.inc
+++ b/recipes/gcc/gcc-3.3.4.inc
@@ -1,5 +1,7 @@
require gcc-common.inc
+INC_PR = "r10"
+
SRC_URI = "${GNU_MIRROR}/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-gotoff.dpatch;patch=1;pnum=0 \
file://arm-ldm.dpatch;patch=1;pnum=0 \
diff --git a/recipes/gcc/gcc-3.4.3.inc b/recipes/gcc/gcc-3.4.3.inc
index 6511dfbd17..72f9042212 100644
--- a/recipes/gcc/gcc-3.4.3.inc
+++ b/recipes/gcc/gcc-3.4.3.inc
@@ -1,5 +1,7 @@
require gcc-common.inc
+INC_PR = "r18"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gcc34-reverse-compare.patch;patch=1 \
file://gcc34-arm-ldm.patch;patch=1 \
diff --git a/recipes/gcc/gcc-3.4.4.inc b/recipes/gcc/gcc-3.4.4.inc
index 2bed5f8959..9a02c5d20b 100644
--- a/recipes/gcc/gcc-3.4.4.inc
+++ b/recipes/gcc/gcc-3.4.4.inc
@@ -1,5 +1,7 @@
require gcc-common.inc
+INC_PR = "r14"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gcc34-reverse-compare.patch;patch=1 \
file://gcc34-arm-ldm.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.1.0.inc b/recipes/gcc/gcc-4.1.0.inc
index d6f6198013..7bb1a34f76 100644
--- a/recipes/gcc/gcc-4.1.0.inc
+++ b/recipes/gcc/gcc-4.1.0.inc
@@ -1,5 +1,7 @@
require gcc-common.inc
+INC_PR = "r9"
+
DEFAULT_PREFERENCE = "-1"
# Use the same patches as gcc-4.1.1 does
diff --git a/recipes/gcc/gcc-4.1.1.inc b/recipes/gcc/gcc-4.1.1.inc
index f16928479b..20da89aee6 100644
--- a/recipes/gcc/gcc-4.1.1.inc
+++ b/recipes/gcc/gcc-4.1.1.inc
@@ -2,6 +2,8 @@ require gcc-common.inc
DEPENDS = "mpfr gmp"
+INC_PR = "r23"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
file://110-arm-eabi.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.1.2.inc b/recipes/gcc/gcc-4.1.2.inc
index ed4e3c408d..2eaa133f97 100644
--- a/recipes/gcc/gcc-4.1.2.inc
+++ b/recipes/gcc/gcc-4.1.2.inc
@@ -2,6 +2,8 @@ require gcc-common.inc
DEPENDS = "mpfr gmp"
+INC_PR = "r20"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
file://110-arm-eabi.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.2.2.inc b/recipes/gcc/gcc-4.2.2.inc
index 7bb17cefed..fcebabc112 100644
--- a/recipes/gcc/gcc-4.2.2.inc
+++ b/recipes/gcc/gcc-4.2.2.inc
@@ -3,6 +3,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r14"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
file://103-uclibc-conf-noupstream.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.2.3.inc b/recipes/gcc/gcc-4.2.3.inc
index 7d623f53e3..b324f176dd 100644
--- a/recipes/gcc/gcc-4.2.3.inc
+++ b/recipes/gcc/gcc-4.2.3.inc
@@ -3,6 +3,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r10"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
file://103-uclibc-conf-noupstream.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.3.1.inc b/recipes/gcc/gcc-4.3.1.inc
index d5390d7f27..f475eba417 100644
--- a/recipes/gcc/gcc-4.3.1.inc
+++ b/recipes/gcc/gcc-4.3.1.inc
@@ -7,6 +7,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r18"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
file://fedora/gcc43-ia64-libunwind.patch;patch=1;pnum=0 \
diff --git a/recipes/gcc/gcc-4.3.2.inc b/recipes/gcc/gcc-4.3.2.inc
index 967eb92285..a6e6b7bd19 100644
--- a/recipes/gcc/gcc-4.3.2.inc
+++ b/recipes/gcc/gcc-4.3.2.inc
@@ -7,6 +7,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r8"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
file://fedora/gcc43-ia64-libunwind.patch;patch=1;pnum=0 \
diff --git a/recipes/gcc/gcc-4.4.0.inc b/recipes/gcc/gcc-4.4.0.inc
index 3cb9763545..6ea9123460 100644
--- a/recipes/gcc/gcc-4.4.0.inc
+++ b/recipes/gcc/gcc-4.4.0.inc
@@ -7,6 +7,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r1"
+
FILESPATHPKG .= ":gcc-$PV"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
diff --git a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
index 409970be5f..dadb5b04f6 100644
--- a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
@@ -1,6 +1,6 @@
inherit canadian-sdk
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
diff --git a/recipes/gcc/gcc-cross-sdk_3.3.4.bb b/recipes/gcc/gcc-cross-sdk_3.3.4.bb
index ed9c18c557..525d1822b8 100644
--- a/recipes/gcc/gcc-cross-sdk_3.3.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_3.3.4.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_3.4.3.bb b/recipes/gcc/gcc-cross-sdk_3.4.3.bb
index 0b1f6613bf..78c4cc0f4f 100644
--- a/recipes/gcc/gcc-cross-sdk_3.4.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_3.4.4.bb b/recipes/gcc/gcc-cross-sdk_3.4.4.bb
index e3346590d5..6cb136a3d2 100644
--- a/recipes/gcc/gcc-cross-sdk_3.4.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.0.bb b/recipes/gcc/gcc-cross-sdk_4.1.0.bb
index 6b6097fb00..f133db31b1 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.0.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.0.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.1.bb b/recipes/gcc/gcc-cross-sdk_4.1.1.bb
index a6418f6404..f133db31b1 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.2.bb b/recipes/gcc/gcc-cross-sdk_4.1.2.bb
index 7bc24806bb..9a9eb8ca56 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.2.bb b/recipes/gcc/gcc-cross-sdk_4.2.2.bb
index a326263c06..27a7ae0a7f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.3.bb b/recipes/gcc/gcc-cross-sdk_4.2.3.bb
index 297bd8ece8..27a7ae0a7f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.4.bb b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
index c5a0a1aa88..ab52a9ae04 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.1.bb b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
index 45557b6003..27a7ae0a7f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r15"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.2.bb b/recipes/gcc/gcc-cross-sdk_4.3.2.bb
index 297bd8ece8..27a7ae0a7f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.3.bb b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
index 27a7ae0a7f..6be2538cd5 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.4.0.bb b/recipes/gcc/gcc-cross-sdk_4.4.0.bb
index a62d13bd2c..513cca1ddc 100644
--- a/recipes/gcc/gcc-cross-sdk_4.4.0.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.4.0.bb
@@ -4,7 +4,7 @@ require gcc-${PV}.inc
require gcc-cross-sdk.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
-PR = "r0"
+PR = "${INC_PR}.1"
DEPENDS += "gmp-native mpfr-native"
diff --git a/recipes/gcc/gcc-cross_3.3.4.bb b/recipes/gcc/gcc-cross_3.3.4.bb
index 462b9cdc66..0bf1951bea 100644
--- a/recipes/gcc/gcc-cross_3.3.4.bb
+++ b/recipes/gcc/gcc-cross_3.3.4.bb
@@ -1,4 +1,4 @@
-PR ="r10"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross.inc
diff --git a/recipes/gcc/gcc-cross_3.4.3.bb b/recipes/gcc/gcc-cross_3.4.3.bb
index 0ecee8ad89..0bf1951bea 100644
--- a/recipes/gcc/gcc-cross_3.4.3.bb
+++ b/recipes/gcc/gcc-cross_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r18"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross.inc
diff --git a/recipes/gcc/gcc-cross_3.4.4.bb b/recipes/gcc/gcc-cross_3.4.4.bb
index 43d4b76037..0bf1951bea 100644
--- a/recipes/gcc/gcc-cross_3.4.4.bb
+++ b/recipes/gcc/gcc-cross_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross.inc
diff --git a/recipes/gcc/gcc-cross_4.1.0.bb b/recipes/gcc/gcc-cross_4.1.0.bb
index 7675e473d3..9513c657f3 100644
--- a/recipes/gcc/gcc-cross_4.1.0.bb
+++ b/recipes/gcc/gcc-cross_4.1.0.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc-cross_4.1.1.bb b/recipes/gcc/gcc-cross_4.1.1.bb
index da797597d7..08ae7a552c 100644
--- a/recipes/gcc/gcc-cross_4.1.1.bb
+++ b/recipes/gcc/gcc-cross_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r22"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc-cross_4.1.2.bb b/recipes/gcc/gcc-cross_4.1.2.bb
index 2effd3e62e..85f90b31a1 100644
--- a/recipes/gcc/gcc-cross_4.1.2.bb
+++ b/recipes/gcc/gcc-cross_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r20"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc-cross_4.2.2.bb b/recipes/gcc/gcc-cross_4.2.2.bb
index 8e20d03e68..4e7fc479d1 100644
--- a/recipes/gcc/gcc-cross_4.2.2.bb
+++ b/recipes/gcc/gcc-cross_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc-cross_4.2.3.bb b/recipes/gcc/gcc-cross_4.2.3.bb
index 816eddba19..4e7fc479d1 100644
--- a/recipes/gcc/gcc-cross_4.2.3.bb
+++ b/recipes/gcc/gcc-cross_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc-cross_4.3.1.bb b/recipes/gcc/gcc-cross_4.3.1.bb
index 2764039081..398ee2ee79 100644
--- a/recipes/gcc/gcc-cross_4.3.1.bb
+++ b/recipes/gcc/gcc-cross_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r18"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc-cross_4.3.2.bb b/recipes/gcc/gcc-cross_4.3.2.bb
index 598da3c912..5eb6b5fbe8 100644
--- a/recipes/gcc/gcc-cross_4.3.2.bb
+++ b/recipes/gcc/gcc-cross_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
diff --git a/recipes/gcc/gcc-cross_4.4.0.bb b/recipes/gcc/gcc-cross_4.4.0.bb
index 731a956ef2..4db1b33945 100644
--- a/recipes/gcc/gcc-cross_4.4.0.bb
+++ b/recipes/gcc/gcc-cross_4.4.0.bb
@@ -2,7 +2,7 @@ require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
require gcc-package-cross.inc
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/recipes/gcc/gcc-native_3.4.4.bb b/recipes/gcc/gcc-native_3.4.4.bb
index c3f8106d3a..5686b4bc93 100644
--- a/recipes/gcc/gcc-native_3.4.4.bb
+++ b/recipes/gcc/gcc-native_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc-package-sdk.inc b/recipes/gcc/gcc-package-sdk.inc
index 3d9cc0c53a..dcf2c890e4 100644
--- a/recipes/gcc/gcc-package-sdk.inc
+++ b/recipes/gcc/gcc-package-sdk.inc
@@ -48,10 +48,9 @@ do_install () {
# Create the ${prefix}/${TARGET_SYS}/bin/* symlinks
install -d ${D}${prefix}/${TARGET_SYS}/bin/
for l in ${D}${bindir}/*; do
- echo $l
- ln -sf "../../${layout_base_bindir}/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`"
+ ln -sf "../../`basename ${bindir}`/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`"
done
- ln -sf "${bindir}/${TARGET_PREFIX}gcc${EXEEXT}" "${D}${prefix}/${TARGET_SYS}/bin/cc${EXEEXT}"
+ ln -sf "../../`basename ${bindir}`/${TARGET_PREFIX}gcc${EXEEXT}" "${D}${prefix}/${TARGET_SYS}/bin/cc${EXEEXT}"
# Manually run the target stripper since we won't get it run by
# the packaging.
diff --git a/recipes/gcc/gcc_3.3.4.bb b/recipes/gcc/gcc_3.3.4.bb
index 1bbab50930..fdafce2474 100644
--- a/recipes/gcc/gcc_3.3.4.bb
+++ b/recipes/gcc/gcc_3.3.4.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_3.4.3.bb b/recipes/gcc/gcc_3.4.3.bb
index fb5a85a4b5..fdafce2474 100644
--- a/recipes/gcc/gcc_3.4.3.bb
+++ b/recipes/gcc/gcc_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r17"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_3.4.4.bb b/recipes/gcc/gcc_3.4.4.bb
index 73e908ae24..fdafce2474 100644
--- a/recipes/gcc/gcc_3.4.4.bb
+++ b/recipes/gcc/gcc_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r12"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.1.0.bb b/recipes/gcc/gcc_4.1.0.bb
index 5e2598079b..fdafce2474 100644
--- a/recipes/gcc/gcc_4.1.0.bb
+++ b/recipes/gcc/gcc_4.1.0.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.1.1.bb b/recipes/gcc/gcc_4.1.1.bb
index 3d202f9930..fdafce2474 100644
--- a/recipes/gcc/gcc_4.1.1.bb
+++ b/recipes/gcc/gcc_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r23"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.1.2.bb b/recipes/gcc/gcc_4.1.2.bb
index 711aa35a32..22465d50d7 100644
--- a/recipes/gcc/gcc_4.1.2.bb
+++ b/recipes/gcc/gcc_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r15"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.2.2.bb b/recipes/gcc/gcc_4.2.2.bb
index f0471d473f..6b20b47f1a 100644
--- a/recipes/gcc/gcc_4.2.2.bb
+++ b/recipes/gcc/gcc_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.2.3.bb b/recipes/gcc/gcc_4.2.3.bb
index ca22e0f69c..6b20b47f1a 100644
--- a/recipes/gcc/gcc_4.2.3.bb
+++ b/recipes/gcc/gcc_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.3.1.bb b/recipes/gcc/gcc_4.3.1.bb
index af35244ec1..2153f272ee 100644
--- a/recipes/gcc/gcc_4.3.1.bb
+++ b/recipes/gcc/gcc_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r12"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
diff --git a/recipes/gcc/gcc_4.3.2.bb b/recipes/gcc/gcc_4.3.2.bb
index fddf437351..60180755c9 100644
--- a/recipes/gcc/gcc_4.3.2.bb
+++ b/recipes/gcc/gcc_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
diff --git a/recipes/gcc/gcc_4.4.0.bb b/recipes/gcc/gcc_4.4.0.bb
index 6ac2b58305..9773205c52 100644
--- a/recipes/gcc/gcc_4.4.0.bb
+++ b/recipes/gcc/gcc_4.4.0.bb
@@ -1,7 +1,7 @@
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-PR = "r0"
+PR = "${INC_PR}.1"
# GCC 4.4.0 installs crt* in a '4.4.0' dir....
FILES_${PN} += "\