summaryrefslogtreecommitdiff
path: root/recipes/freesmartphone/fsotdld_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fsotdld_git.bb')
-rw-r--r--recipes/freesmartphone/fsotdld_git.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsotdld_git.bb b/recipes/freesmartphone/fsotdld_git.bb
index 3ae74cef8a..31789248ef 100644
--- a/recipes/freesmartphone/fsotdld_git.bb
+++ b/recipes/freesmartphone/fsotdld_git.bb
@@ -1,7 +1,20 @@
require cornucopia.inc
inherit fso-plugin
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
PV = "0.0.0+gitr${SRCREV}"
DEPENDS += "libfsotransport libfsoresource"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "fsotdld"
+INITSCRIPT_PARAMS = "defaults 27"
+
+SRC_URI += "file://fsotdld"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fsotdld ${D}${sysconfdir}/init.d/
+}
+