summaryrefslogtreecommitdiff
path: root/recipes/efl1/edje_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/efl1/edje_svn.bb')
-rw-r--r--recipes/efl1/edje_svn.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/recipes/efl1/edje_svn.bb b/recipes/efl1/edje_svn.bb
index 7f94b08256..bfd00ecb96 100644
--- a/recipes/efl1/edje_svn.bb
+++ b/recipes/efl1/edje_svn.bb
@@ -1,11 +1,22 @@
DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
-DEPENDS = "eet evas ecore embryo edje-native"
+DEPENDS = "lua5.1 eet evas ecore embryo edje-native"
LICENSE = "MIT BSD"
PV = "0.9.92.060+svnr${SRCREV}"
PR = "r4"
inherit efl
+# The new lua stuff is a bit broken...
+do_configure_append() {
+ for i in $(find "${S}" -name "Makefile") ; do
+ sed -i -e 's:-L/usr/local/lib::g' $i
+ done
+}
+
+do_compile_append() {
+ sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
+}
+
# gain some extra performance at the expense of RAM - generally i'd say bad
# and a possible source of bugs
#EXTRA_OECONF = "--enable-edje-program-cache"