summaryrefslogtreecommitdiff
path: root/recipes/dropbear
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dropbear')
-rw-r--r--recipes/dropbear/dropbear-early_1.0.bb2
-rw-r--r--recipes/dropbear/dropbear.inc4
-rwxr-xr-xrecipes/dropbear/dropbear/init7
-rw-r--r--recipes/dropbear/dropbear_0.49.bb2
-rw-r--r--recipes/dropbear/dropbear_0.51.bb2
-rw-r--r--recipes/dropbear/dropbear_0.52.bb2
6 files changed, 12 insertions, 7 deletions
diff --git a/recipes/dropbear/dropbear-early_1.0.bb b/recipes/dropbear/dropbear-early_1.0.bb
index 2042400b8b..ea815f2a0e 100644
--- a/recipes/dropbear/dropbear-early_1.0.bb
+++ b/recipes/dropbear/dropbear-early_1.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Allow to start dropbear soon after boot, depending on kernel command line option."
SECTION = "devel"
RDEPENDS_${PN} = "dropbear"
-PR = "r3"
+PR = "r4"
SRC_URI = "file://dropbear-early"
diff --git a/recipes/dropbear/dropbear.inc b/recipes/dropbear/dropbear.inc
index 056732fab3..af00129632 100644
--- a/recipes/dropbear/dropbear.inc
+++ b/recipes/dropbear/dropbear.inc
@@ -4,7 +4,9 @@ SECTION = "console/network"
LICENSE = "MIT"
DEPENDS = "zlib"
PROVIDES = "ssh sshd"
-RPROVIDES = "ssh sshd"
+RPROVIDES_${PN} = "ssh sshd"
+
+INC_PR = "r4"
SRC_URI = "\
http://matt.ucc.asn.au/dropbear/dropbear-${PV}.tar.bz2 \
diff --git a/recipes/dropbear/dropbear/init b/recipes/dropbear/dropbear/init
index 5c8dfc12a8..275aa328df 100755
--- a/recipes/dropbear/dropbear/init
+++ b/recipes/dropbear/dropbear/init
@@ -19,6 +19,9 @@ test "$NO_START" = "0" || exit 0
test -x "$DAEMON" || exit 0
test ! -h /var/service/dropbear || exit 0
+# Allows comma-separated list of addresses/ports
+DROPBEAR_PORT=`echo $DROPBEAR_PORT | sed "s/,/ -p /g"`
+
readonly_rootfs=0
for flag in `awk '{ if ($2 == "/") { split($4,FLAGS,",") } }; END { for (f in FLAGS) print FLAGS[f] }' </proc/mounts`; do
case $flag in
@@ -74,7 +77,7 @@ case "$1" in
test -f $DROPBEAR_RSAKEY && KEY_ARGS="$KEY_ARGS -r $DROPBEAR_RSAKEY"
start-stop-daemon -S \
-x "$DAEMON" -- $KEY_ARGS \
- -p "$DROPBEAR_PORT" $DROPBEAR_EXTRA_ARGS
+ -p $DROPBEAR_PORT $DROPBEAR_EXTRA_ARGS
echo "$NAME."
;;
stop)
@@ -91,7 +94,7 @@ case "$1" in
test -f $DROPBEAR_RSAKEY && KEY_ARGS="$KEY_ARGS -r $DROPBEAR_RSAKEY"
start-stop-daemon -S \
-x "$DAEMON" -- $KEY_ARGS \
- -p "$DROPBEAR_PORT" $DROPBEAR_EXTRA_ARGS
+ -p $DROPBEAR_PORT $DROPBEAR_EXTRA_ARGS
echo "$NAME."
;;
*)
diff --git a/recipes/dropbear/dropbear_0.49.bb b/recipes/dropbear/dropbear_0.49.bb
index 79a2de6630..9ebce14c91 100644
--- a/recipes/dropbear/dropbear_0.49.bb
+++ b/recipes/dropbear/dropbear_0.49.bb
@@ -1,6 +1,6 @@
require dropbear.inc
-PR = "r2"
+PR = "${INC_PR}.0"
SRC_URI += "file://scp-argument-fix.patch"
diff --git a/recipes/dropbear/dropbear_0.51.bb b/recipes/dropbear/dropbear_0.51.bb
index 168f5bbe00..b927f3203b 100644
--- a/recipes/dropbear/dropbear_0.51.bb
+++ b/recipes/dropbear/dropbear_0.51.bb
@@ -1,5 +1,5 @@
require dropbear.inc
-PR = "r1.01"
+PR = "${INC_PR}.0"
SRC_URI += "file://no-host-lookup.patch"
diff --git a/recipes/dropbear/dropbear_0.52.bb b/recipes/dropbear/dropbear_0.52.bb
index 0e36b99509..975788a175 100644
--- a/recipes/dropbear/dropbear_0.52.bb
+++ b/recipes/dropbear/dropbear_0.52.bb
@@ -1,5 +1,5 @@
require dropbear.inc
-PR = "r0"
+PR = "${INC_PR}.0"
SRC_URI += "file://no-host-lookup.patch"