summaryrefslogtreecommitdiff
path: root/recipes/disko/disko_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/disko/disko_git.bb')
-rw-r--r--recipes/disko/disko_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/disko/disko_git.bb b/recipes/disko/disko_git.bb
new file mode 100644
index 0000000000..657fb40cec
--- /dev/null
+++ b/recipes/disko/disko_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Disko is an application framework, that can be used to develop GUI applications for embedded devices. It is closely connected to the DirectFB"
+LICENSE = "GPL"
+PV = "1.1.5+gitr${SRCREV}"
+PR = "r0"
+
+DEPENDS = "sqlite3 libpng jpeg curl alsa-lib taglib directfb libxml2 virtual/libx11 libsigc++-2.0 hal \
+ libxv libxxf86vm"
+
+SRC_URI = "git://www.diskohq.org/disko.git;protocol=git \
+ file://header.patch;patch=1 \
+ file://pkgconfig.patch;patch=1 \
+ "
+SRCREV = "bf29da8c0060a2b4f0f9593524ca71aa1adfbc0c"
+
+S = "${WORKDIR}/git"
+
+inherit scons pkgconfig
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} graphics=all PREFIX=${prefix} prefix=${prefix} || \
+ oefatal "scons build execution failed."
+}