summaryrefslogtreecommitdiff
path: root/recipes/at/at-3.1.8/use-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/at/at-3.1.8/use-ldflags.patch')
-rw-r--r--recipes/at/at-3.1.8/use-ldflags.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/at/at-3.1.8/use-ldflags.patch b/recipes/at/at-3.1.8/use-ldflags.patch
new file mode 100644
index 0000000000..57e411ddbc
--- /dev/null
+++ b/recipes/at/at-3.1.8/use-ldflags.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.in 2010-04-16 17:35:22.000000000 +0400
++++ b/Makefile.in 2010-04-16 17:36:37.000000000 +0400
+@@ -70,13 +70,13 @@ LIST = Filelist Filelist.asc
+ all: at atd atrun
+
+ at: $(ATOBJECTS)
+- $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
++ $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB) $(LDFLAGS)
+ rm -f $(CLONES)
+ $(LN_S) -f at atq
+ $(LN_S) -f at atrm
+
+ atd: $(RUNOBJECTS)
+- $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS)
++ $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(LDFLAGS)
+
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y