summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/fastcgi/fastcgi_2.4.0.bb4
-rw-r--r--packages/lighttpd/lighttpd_1.4.18.bb10
2 files changed, 12 insertions, 2 deletions
diff --git a/packages/fastcgi/fastcgi_2.4.0.bb b/packages/fastcgi/fastcgi_2.4.0.bb
index a42949cb96..beada396cd 100644
--- a/packages/fastcgi/fastcgi_2.4.0.bb
+++ b/packages/fastcgi/fastcgi_2.4.0.bb
@@ -1,6 +1,6 @@
LICENSE = "Open Market"
DESCRIPTION = "Fast CGI backend (web server to CGI handler) library"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.fastcgi.com/dist/fcgi-${PV}.tar.gz"
@@ -8,6 +8,8 @@ S=${WORKDIR}/fcgi-${PV}
LEAD_SONAME = "libfcgi.so*"
+PARALLEL_MAKE=""
+
inherit autotools pkgconfig
do_stage() {
diff --git a/packages/lighttpd/lighttpd_1.4.18.bb b/packages/lighttpd/lighttpd_1.4.18.bb
index 14a6bd0f25..a83efcaf40 100644
--- a/packages/lighttpd/lighttpd_1.4.18.bb
+++ b/packages/lighttpd/lighttpd_1.4.18.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Web server"
SECTION = "net"
LICENSE = "BSD"
DEPENDS = "libpcre"
+PR = "r1"
SRC_URI = "http://www.lighttpd.net/download/lighttpd-${PV}.tar.gz \
file://configure.in.patch;patch=1 \
@@ -37,4 +38,11 @@ do_stage() {
autotools_stage_all
}
-FILES_${PN} += "${libdir}/mod_*.so ${sysconfdir} /www"
+FILES_${PN} += "${sysconfdir} /www"
+
+PACKAGES_DYNAMIC = "lighttpd-module-*"
+
+python populate_packages_prepend () {
+ lighttpd_libdir = bb.data.expand('${libdir}', d)
+ do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
+}