summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/e17/e-wm/Xsession.d/98enlightenment2
-rw-r--r--packages/e17/e-wm/applications.menu93
-rw-r--r--packages/e17/e-wm_0.16.999.038.bb11
-rw-r--r--packages/glib-2.0/glib.inc2
-rw-r--r--packages/parted/parted_1.8.7.bb7
-rw-r--r--packages/tasks/task-gpephone.bb7
6 files changed, 113 insertions, 9 deletions
diff --git a/packages/e17/e-wm/Xsession.d/98enlightenment b/packages/e17/e-wm/Xsession.d/98enlightenment
index 65f46284a9..7913888438 100644
--- a/packages/e17/e-wm/Xsession.d/98enlightenment
+++ b/packages/e17/e-wm/Xsession.d/98enlightenment
@@ -1,3 +1,3 @@
#!/bin/sh
-exec enlightenment \ No newline at end of file
+exec enlightenment_start
diff --git a/packages/e17/e-wm/applications.menu b/packages/e17/e-wm/applications.menu
new file mode 100644
index 0000000000..e163864acf
--- /dev/null
+++ b/packages/e17/e-wm/applications.menu
@@ -0,0 +1,93 @@
+<?xml version="1.0"?>
+<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN" "http://standards.freedesktop.org/menu-spec/menu-1.0.dtd">
+<Menu>
+ <Name>Applications</Name>
+ <!-- <Directory>Applications.directory</Directory> -->
+
+ <!-- Read standard .directory and .desktop file locations -->
+ <DefaultAppDirs>/usr/share/applications</DefaultAppDirs>
+ <DefaultDirectoryDirs/>
+
+ <Menu>
+ <Name>Office</Name>
+ <Directory>Office.directory</Directory>
+ <Include>
+ <And>
+ <Category>Office</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Multimedia</Name>
+ <Directory>Multimedia.directory</Directory>
+ <Include>
+ <And>
+ <Category>AudioVideo</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Graphics</Name>
+ <Directory>Graphics.directory</Directory>
+ <Include>
+ <And>
+ <Category>Graphics</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Games</Name>
+ <Directory>Games.directory</Directory>
+ <Include>
+ <And>
+ <Category>Games</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Internet</Name>
+ <Directory>Internet.directory</Directory>
+ <Include>
+ <And>
+ <Category>Network</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Settings</Name>
+ <Directory>Settings.directory</Directory>
+ <Include>
+ <And>
+ <Category>SystemSettings</Category>
+ </And>
+ </Include>
+ </Menu>
+
+ <Menu>
+ <Name>Accessories</Name>
+ <Directory>Accessories.directory</Directory>
+ <Include>
+ <And>
+ <Or>
+ <Category>Applications</Category>
+ <Category>Utility</Category>
+ </Or>
+ <Not>
+ <Category>System</Category>
+ <Category>Office</Category>
+ <Category>Internet</Category>
+ <Category>AudioVideo</Category>
+ <Category>Graphics</Category>
+ <Category>Games</Category>
+ </Not>
+ </And>
+ </Include>
+ </Menu>
+
+</Menu>
+
diff --git a/packages/e17/e-wm_0.16.999.038.bb b/packages/e17/e-wm_0.16.999.038.bb
index 1204ed9ecc..12784ea18f 100644
--- a/packages/e17/e-wm_0.16.999.038.bb
+++ b/packages/e17/e-wm_0.16.999.038.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "E17 - the Enlightenment Window Mananger"
DEPENDS = "eet evas ecore edje efreet"
LICENSE = "MIT"
-PR = "r6"
+PR = "r7"
inherit e update-alternatives
SRC_URI = "${E_URI}/enlightenment-${PV}.tar.gz \
file://fix-configure.patch;patch=1 \
file://set-autoscroll-defaults.patch;patch=1 \
- file://Xsession.d/98enlightenment"
+ file://Xsession.d/98enlightenment \
+ file://applications.menu \
+ "
S = "${WORKDIR}/enlightenment-${PV}"
@@ -35,9 +37,12 @@ do_compile_prepend() {
do_install_append() {
install -d ${D}/${sysconfdir}/X11/Xsession.d
install -m 755 ${WORKDIR}/Xsession.d/98enlightenment ${D}/${sysconfdir}/X11/Xsession.d
+
+ install -d ${D}/${sysconfdir}/xdg/menus
+ install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
}
-ALTERNATIVE_PATH = "${bindir}/enlightenment"
+ALTERNATIVE_PATH = "${bindir}/enlightenment_start"
ALTERNATIVE_NAME = "x-window-manager"
ALTERNATIVE_LINK = "${bindir}/x-window-manager"
ALTERNATIVE_PRIORITY = "16"
diff --git a/packages/glib-2.0/glib.inc b/packages/glib-2.0/glib.inc
index 57f4af4cc4..7abd755891 100644
--- a/packages/glib-2.0/glib.inc
+++ b/packages/glib-2.0/glib.inc
@@ -8,7 +8,7 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS += "glib-2.0-native gtk-doc"
DEPENDS += "virtual/libiconv virtual/libintl"
-PACKAGES =+ "${PN}-dev glib-2.0-utils "
+PACKAGES =+ " glib-2.0-utils "
PR = "r1"
diff --git a/packages/parted/parted_1.8.7.bb b/packages/parted/parted_1.8.7.bb
index f29771d5a4..dcb3ad7cb4 100644
--- a/packages/parted/parted_1.8.7.bb
+++ b/packages/parted/parted_1.8.7.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
LICENSE = "GPLv2"
SECTION = "console/tools"
DEPENDS = "readline e2fsprogs-libs"
-PR = "r0"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz"
@@ -20,3 +20,8 @@ do_configure() {
do_stage() {
autotools_stage_all
}
+
+# Requires autoconf 2.61. Without it, will build, but there
+# will be link errors when some other package will link against
+# libparted.
+DEFAULT_PREFERENCE = "-1"
diff --git a/packages/tasks/task-gpephone.bb b/packages/tasks/task-gpephone.bb
index 96a27e6ed2..b81338a676 100644
--- a/packages/tasks/task-gpephone.bb
+++ b/packages/tasks/task-gpephone.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Task packages for GPE Palmtop Environment Phone Edition"
-PR = "r4"
+PR = "r5"
LICENSE = "MIT"
ALLOW_EMPTY = "1"
@@ -18,12 +18,13 @@ RDEPENDS_gpephone-base-depends = "\
RDEPENDS_gpephone-task-development = "\
rxvt-unicode \
- xmonobut \
gpe-terminal \
gpe-edit \
gdb \
strace \
- e2fsprogs"
+ e2fsprogs \
+ bluez-utils-compat \
+ minicom"
RDEPENDS_gpephone-task-base = "\
cms92init \