summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/cairo/cairo_1.0.0.bb15
-rw-r--r--packages/libao/libao_0.8.6.bb26
-rw-r--r--packages/libdvb/libdvb_0.5.5.1.bb3
-rw-r--r--packages/linux/linux-openzaurus_2.6.13-rc5-mm1.bb51
-rw-r--r--packages/meta/openslug-packages.bb1
-rw-r--r--packages/musicpd/mpd_0.11.5.bb23
-rw-r--r--packages/qc-usb/qc-usb-messenger_0.8.bb (renamed from packages/qc-usb-messenger/qc-usb-messenger_0.8.bb)0
-rw-r--r--packages/syslog-ng/files/.mtn2git_empty (renamed from packages/qc-usb-messenger/.mtn2git_empty)0
-rw-r--r--packages/syslog-ng/files/initscript45
-rw-r--r--packages/syslog-ng/syslog-ng_1.6.8.bb21
10 files changed, 159 insertions, 26 deletions
diff --git a/packages/cairo/cairo_1.0.0.bb b/packages/cairo/cairo_1.0.0.bb
new file mode 100644
index 0000000000..aa97a9f4de
--- /dev/null
+++ b/packages/cairo/cairo_1.0.0.bb
@@ -0,0 +1,15 @@
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@debian.org>"
+DEPENDS = "x11 libpng fontconfig libxrender"
+DESCRIPTION = "Cairo graphics library"
+LICENSE = "MPL LGPL"
+PR = "r1"
+
+SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_runmake install DESTDIR="" bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
+}
diff --git a/packages/libao/libao_0.8.6.bb b/packages/libao/libao_0.8.6.bb
new file mode 100644
index 0000000000..8c2601bce8
--- /dev/null
+++ b/packages/libao/libao_0.8.6.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library"
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "http://www.xiph.org/ao/src/libao-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-alsa --disable-alsa09 \
+ --disable-arts --disable-nas"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/ao
+ install -m 0644 ${S}/include/ao/ao.h ${S}/include/ao/os_types.h \
+ ${S}/include/ao/plugin.h ${STAGING_INCDIR}/ao/
+
+ oe_libinstall -so -C src libao ${STAGING_LIBDIR}
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ao.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+FILES_${PN} += "${libdir}/ao/plugins-2/*.so"
diff --git a/packages/libdvb/libdvb_0.5.5.1.bb b/packages/libdvb/libdvb_0.5.5.1.bb
index 62ce3c61e5..9de579917c 100644
--- a/packages/libdvb/libdvb_0.5.5.1.bb
+++ b/packages/libdvb/libdvb_0.5.5.1.bb
@@ -1,10 +1,11 @@
LICENSE = "GPL"
DESCRIPTION = "Linux Digital Video Broadcast library"
+DESCRIPTION_libdvb-dev = "Headers for libdvb development"
HOMEPAGE = "http://www.metzlerbros.org/dvb/index.html"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org"
SECTION = "libs"
PRIORITY = "optional"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.metzlerbros.org/dvb/${PN}-${PV}.tar.gz"
S = "${WORKDIR}/${PN}-${PV}"
diff --git a/packages/linux/linux-openzaurus_2.6.13-rc5-mm1.bb b/packages/linux/linux-openzaurus_2.6.13-rc5-mm1.bb
index 065d5d9eb8..f96a086835 100644
--- a/packages/linux/linux-openzaurus_2.6.13-rc5-mm1.bb
+++ b/packages/linux/linux-openzaurus_2.6.13-rc5-mm1.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
#KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
KV = "${@bb.data.getVar('PV',d,True)}"
-PR = "r11"
+PR = "r14"
DOSRC = "http://www.do13.in-berlin.de/openzaurus/patches"
RPSRC = "http://www.rpsys.net/openzaurus/patches"
@@ -38,23 +38,36 @@ BASRC = "http://www.orca.cx/zaurus/patches"
# Patches submitted upstream are towards top of this list
+# Hacks should clearly named and at the bottom
SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.gz \
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.13-rc5.bz2;patch=1 \
ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.13-rc5/2.6.13-rc5-mm1/2.6.13-rc5-mm1.bz2;patch=1 \
${RPSRC}/reverse_pagefault-r3.patch;patch=1 \
${RPSRC}/corgi_tspmufix-r0.patch;patch=1 \
${RPSRC}/nwfpe_x80-r0.patch;patch=1 \
+ ${DOSRC}/mmc-bulk-r0.patch;patch=1 \
+ ${RPSRC}/spitz_usbsuspend-r0.patch;patch=1 \
+ ${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
+ ${RPSRC}/pxa_pcmcia_init-r0.patch;patch=1 \
+ ${RPSRC}/pxa_remove_static-r0.patch;patch=1 \
+ ${RPSRC}/pxafb_hsync-r2.patch;patch=1 \
+ ${RPSRC}/pxa27x_extraregs-r3.patch;patch=1 \
+ ${RPSRC}/sharp_multi_pcmcia-r3.patch;patch=1 \
+ ${RPSRC}/sharpsl_ssp-r0.patch;patch=1 \
+ ${RPSRC}/sharpsl_lcd-r1.patch;patch=1 \
+ ${RPSRC}/sharpsl_ts-r2.patch;patch=1 \
+ ${RPSRC}/sharpsl_bl-r0.patch;patch=1 \
+ ${RPSRC}/sharpsl_pm-r0.patch;patch=1 \
+ ${RPSRC}/corgi_pm-r0.patch;patch=1 \
+ ${RPSRC}/spitzkbd-r1.patch;patch=1 \
+ ${RPSRC}/spitzcf-r1.patch;patch=1 \
+ ${RPSRC}/spitz_usbhost-r0.patch;patch=1 \
${RPSRC}/pxa_rtc-r1.patch;patch=1 \
${RPSRC}/pxa_irda-r2.patch;patch=1 \
- ${RPSRC}/sharp_multi_pcmcia-r3.patch;patch=1 \
- ${RPSRC}/input_power-r2.patch;patch=1 \
- ${RPSRC}/corgi_irda-r2.patch;patch=1 \
- ${RPSRC}/corgi_base_extras4-r0.patch;patch=1 \
+ ${RPSRC}/corgi_irda-r3.patch;patch=1 \
+ ${RPSRC}/input_power-r2.patch;patch=1 \
${RPSRC}/jffs2_longfilename-r0.patch;patch=1 \
- ${RPSRC}/corgi_power-r24.patch;patch=1 \
- ${RPSRC}/corgi_power1-r1.patch;patch=1 \
- ${DOSRC}/mmc-bulk-r0.patch;patch=1 \
- ${RPSRC}/mmc_timeout-r0.patch;patch=1 \
+ ${RPSRC}/sharpsl_bl_kick-r0.patch;patch=1 \
${RPSRC}/corgi_snd-r10.patch;patch=1 \
${DOSRC}/rmk-i2c-pxa-r0.patch;patch=1 \
${RPSRC}/spitz_mtd-r0.patch;patch=1 \
@@ -79,21 +92,12 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.gz \
${DOSRC}/tosa-lcd-r3.patch;patch=1 \
${DOSRC}/tosa-2.6.13-r1.patch;patch=1 \
${RPSRC}/temp/tosa-bl-r5.patch;patch=1 \
- ${RPSRC}/pxa27x_extraregs-r3.patch;patch=1 \
- ${RPSRC}/spitzbase-r5.patch;patch=1 \
- ${RPSRC}/spitzkbd-r1.patch;patch=1 \
- ${RPSRC}/spitzssp-r4.patch;patch=1 \
- ${RPSRC}/spitzbl-r1.patch;patch=1 \
- ${RPSRC}/spitzts-r1.patch;patch=1 \
- ${RPSRC}/spitzcf-r1.patch;patch=1 \
- ${RPSRC}/spitz_power-r1.patch;patch=1 \
- ${RPSRC}/spitz_usbhost-r0.patch;patch=1 \
- ${RPSRC}/spitz_usbsuspend-r0.patch;patch=1 \
+ ${RPSRC}/spitz_base-r8.patch;patch=1 \
+ ${RPSRC}/spitz_pm-r0.patch;patch=1 \
${RPSRC}/scoop_susres-r0.patch;patch=1 \
- ${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
${RPSRC}/pcmcia_dev_ids-r0.patch;patch=1 \
+ ${RPSRC}/mmc_timeout-r0.patch;patch=1 \
${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1 \
- ${RPSRC}/pxa_pcmcia_init-r0.patch;patch=1 \
file://add-oz-release-string.patch;patch=1 \
file://add-elpp-stuff.patch;patch=1 \
file://pxa-serial-hack.patch;patch=1 \
@@ -153,6 +157,11 @@ CMDLINE = "${CMDLINE_CON} ${CMDLINE_ROOT} ${CMDLINE_MEM} debug"
#
ENABLE_ELPP = ${@bb.data.getVar("OZ_KERNEL_ENABLE_ELPP",d,1) or "no"}
+###############################################################
+# module configs specific to this kernel
+#
+module_autoload_pxaficp_ir = "pxaficp_ir"
+
do_configure() {
install -m 0644 ${WORKDIR}/defconfig-${MACHINE} ${S}/.config || die "No default configuration for ${MACHINE} available."
diff --git a/packages/meta/openslug-packages.bb b/packages/meta/openslug-packages.bb
index 2febd8d2b3..80c0a5be09 100644
--- a/packages/meta/openslug-packages.bb
+++ b/packages/meta/openslug-packages.bb
@@ -97,6 +97,7 @@ OPENSLUG_PACKAGES = "\
puppy \
pwc \
python \
+ qc-usb-messenger \
quilt \
reiserfsprogs reiser4progs \
rsync \
diff --git a/packages/musicpd/mpd_0.11.5.bb b/packages/musicpd/mpd_0.11.5.bb
new file mode 100644
index 0000000000..395d69e79e
--- /dev/null
+++ b/packages/musicpd/mpd_0.11.5.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org"
+LICENSE = "GPLv2"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SECTION = "console/multimedia"
+DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.gz"
+
+inherit autotools
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "--enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --without-faad"
diff --git a/packages/qc-usb-messenger/qc-usb-messenger_0.8.bb b/packages/qc-usb/qc-usb-messenger_0.8.bb
index 2720b3af59..2720b3af59 100644
--- a/packages/qc-usb-messenger/qc-usb-messenger_0.8.bb
+++ b/packages/qc-usb/qc-usb-messenger_0.8.bb
diff --git a/packages/qc-usb-messenger/.mtn2git_empty b/packages/syslog-ng/files/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/qc-usb-messenger/.mtn2git_empty
+++ b/packages/syslog-ng/files/.mtn2git_empty
diff --git a/packages/syslog-ng/files/initscript b/packages/syslog-ng/files/initscript
new file mode 100644
index 0000000000..b95e8adc20
--- /dev/null
+++ b/packages/syslog-ng/files/initscript
@@ -0,0 +1,45 @@
+#! /bin/sh
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/syslog-ng and type
+# > update-rc.d syslog-ng defaults 5
+#
+
+
+syslog_ng=/usr/sbin/syslog-ng
+test -x "$syslog_ng" || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting syslog-ng:"
+ start-stop-daemon --start --quiet --exec $syslog_ng
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping syslog-ng:"
+ start-stop-daemon --stop --quiet --pidfile /var/run/syslog-ng.pid
+ echo "."
+ ;;
+ reload|force-reload)
+ start-stop-daemon --stop --quiet --signal 1 --exec $syslog_ng
+ ;;
+ restart)
+ echo "Stopping syslog-ng:"
+ start-stop-daemon --stop --quiet --pidfile /var/run/syslog-ng.pid
+ echo -n "Waiting for syslog-ng to die off"
+ for i in 1 2 3 ;
+ do
+ sleep 1
+ echo -n "."
+ done
+ echo ""
+ echo -n "Starting syslog-ng:"
+ start-stop-daemon --start --quiet --exec $syslog_ng
+ echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/syslog-ng {start|stop|reload|restart|force-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/packages/syslog-ng/syslog-ng_1.6.8.bb b/packages/syslog-ng/syslog-ng_1.6.8.bb
index a4c2fde2d2..bc41020b71 100644
--- a/packages/syslog-ng/syslog-ng_1.6.8.bb
+++ b/packages/syslog-ng/syslog-ng_1.6.8.bb
@@ -1,17 +1,30 @@
-PR = "r4"
+PR = "r7"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org"
+DESCRIPTION = "Alternative system logger daemon"
DEPENDS = "libol"
-SRC_URI = "http://www.balabit.com/downloads/syslog-ng/1.6/src/${PN}-${PV}.tar.gz"
+SRC_URI = "http://www.balabit.com/downloads/syslog-ng/1.6/src/${PN}-${PV}.tar.gz \
+ file://initscript"
S = "${WORKDIR}/${PN}-${PV}"
-inherit autotools
+inherit autotools update-rc.d
EXTRA_OECONF = "--with-libol=${STAGING_BINDIR}/"
CONFFILES_${PN} = "${sysconfdir}/${PN}/syslog-ng.conf"
+INITSCRIPT_NAME = "syslog-ng"
+INITSCRIPT_PARAMS = "defaults 05"
do_install_append() {
install -d ${D}/${sysconfdir}/${PN}
install ${S}/doc/syslog-ng.conf.sample ${D}${sysconfdir}/${PN}/syslog-ng.conf
-
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/initscript ${D}/${sysconfdir}/init.d/syslog-ng
+}
+
+pkg_postinst() {
+ update-rc.d -f syslog remove
+}
+
+pkg_postrm() {
+ update-rc.d syslog add 5
}