summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth_0.51.bb4
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/checkroot.sh169
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/mountall.sh27
-rw-r--r--packages/initscripts/initscripts-slugos_1.0.bb3
-rw-r--r--packages/libsexy/libsexy_0.1.6.bb17
-rw-r--r--packages/meta/slugos-packages.bb2
-rw-r--r--packages/setpwc/files/makefile.diff12
-rw-r--r--packages/setpwc/setpwc_1.1.bb19
-rw-r--r--packages/slugos-init/files/functions14
-rw-r--r--packages/slugos-init/files/leds5
-rw-r--r--packages/slugos-init/slugos-init_0.10.bb2
-rw-r--r--packages/sysvinit/sysvinit/slugos/rcS-default12
-rw-r--r--packages/sysvinit/sysvinit_2.86.bb2
13 files changed, 277 insertions, 11 deletions
diff --git a/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb b/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
index 12833d7dde..ea7aa905fa 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
+++ b/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
@@ -3,9 +3,9 @@ DESCRIPTION = "GPE bluetooth support user interface tool."
SECTION = "gpe"
PRIORITY = "optional"
MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
+PR = "r1"
-
-DEPENDS = "gtk+ libcontactsdb libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus libglade blueprobe bluez-utils-dbus"
+DEPENDS = "gtk+ libcontactsdb libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus libglade blueprobe bluez-utils-dbus"
RDEPENDS = "bluez-utils-dbus blueprobe"
GPE_TARBALL_SUFFIX= "bz2"
diff --git a/packages/initscripts/initscripts-1.0/slugos/checkroot.sh b/packages/initscripts/initscripts-1.0/slugos/checkroot.sh
new file mode 100644
index 0000000000..be640fd254
--- /dev/null
+++ b/packages/initscripts/initscripts-1.0/slugos/checkroot.sh
@@ -0,0 +1,169 @@
+#
+# checkroot.sh Check to root filesystem.
+#
+# Version: @(#)checkroot.sh 2.84 25-Jan-2002 miquels@cistron.nl
+#
+
+. /etc/default/functions
+. /etc/default/rcS
+
+#
+# Set SULOGIN in /etc/default/rcS to yes if you want a sulogin to be spawned
+# from this script *before anything else* with a timeout, like SCO does.
+#
+test "$SULOGIN" = yes && sulogin -t 30 $CONSOLE
+
+#
+# Ensure that bdflush (update) is running before any major I/O is
+# performed (the following fsck is a good example of such activity :).
+#
+test -x /sbin/update && update
+
+#
+# Read /etc/fstab.
+#
+exec 9>&0 </etc/fstab
+rootmode=rw
+rootopts=rw
+swap_on_md=no
+devfs=
+while read fs mnt type opts dump pass junk
+do
+ case "$fs" in
+ ""|\#*)
+ continue;
+ ;;
+ /dev/md*)
+ # Swap on md device.
+ test "$type" = swap && swap_on_md=yes
+ ;;
+ /dev/*)
+ ;;
+ *)
+ # Might be a swapfile.
+ test "$type" = swap && swap_on_md=yes
+ ;;
+ esac
+ test "$type" = devfs && devfs="$fs"
+ test "$mnt" != / && continue
+ rootopts="$opts"
+ test "$pass" = 0 -o "$pass" = "" && ROOTFSCK=no
+ case "$opts" in
+ ro|ro,*|*,ro|*,ro,*)
+ rootmode=ro
+ ;;
+ esac
+done
+exec 0>&9 9>&-
+
+#
+# Activate the swap device(s) in /etc/fstab. This needs to be done
+# before fsck, since fsck can be quite memory-hungry.
+#
+# We don't test whether we're running a 2.[0123].x kernel and md
+# since that's plain too old.
+
+if test "$DOSWAP" != no
+then
+ swaps="$(blkid -t TYPE=swap -o device 2>/dev/null)"
+ if test -n "$swaps"
+ then
+ swapon $swaps 2>/dev/null
+ else
+ swapon -a 2> /dev/null
+ fi
+fi
+
+#
+# Check the root filesystem.
+#
+if test -f /fastboot || test "$ROOTFSCK" != yes
+then
+ test "$ROOTFSCK" = yes && echo "Fast boot, no filesystem check"
+elif test ! -x /sbin/fsck -a ! -x /usr/sbin/fsck
+then
+ echo "/etc/init.d/checkroot.sh: no fsck"
+else
+ leds disk-1 slow
+ #
+ # Ensure that root is quiescent and read-only before fsck'ing.
+ #
+ mount -n -o remount,ro /
+ if test $? = 0
+ then
+ if test -f /forcefsck
+ then
+ force="-f"
+ else
+ force=""
+ fi
+ if test "$FSCKFIX" = yes
+ then
+ fix="-y"
+ else
+ fix="-a"
+ fi
+ spinner="-C"
+ case "$TERM" in
+ dumb|network|unknown|"") spinner="" ;;
+ esac
+ test "$VERBOSE" != no && echo "Checking root filesystem..."
+ fsck $spinner $force $fix /
+ #
+ # If there was a failure, drop into single-user mode.
+ #
+ # NOTE: "failure" is defined as exiting with a return code of
+ # 2 or larger. A return code of 1 indicates that filesystem
+ # errors were corrected but that the boot may proceed.
+ #
+ if test "$?" -gt 1
+ then
+ # Surprise! Re-directing from a HERE document (as in
+ # "cat << EOF") won't work, because the root is read-only.
+ echo
+ echo "fsck failed. Please repair manually and reboot. Please note"
+ echo "that the root filesystem is currently mounted read-only. To"
+ echo "remount it read-write:"
+ echo
+ echo " # mount -n -o remount,rw /"
+ echo
+ echo "CONTROL-D will exit from this shell and REBOOT the system."
+ echo
+ leds system panic
+ leds beep -r 5
+ # Start a single user shell on the console
+ if single_user_ok
+ then
+ sulogin -t 300 $CONSOLE
+ # assume the system is ok now...
+ fi
+ echo "... continuing boot"
+ fi
+ else
+ echo "*** ERROR! Cannot fsck root fs because it is not mounted read-only!"
+ echo
+ fi
+ leds disk-1 off
+fi
+
+#
+# If the root filesystem was not marked as read-only in /etc/fstab,
+# remount the rootfs rw but do not try to change mtab because it
+# is on a ro fs until the remount succeeded. Then clean up old mtabs
+# and finally write the new mtab.
+#
+mount -n -o remount,$rootopts /
+if test "$rootmode" = rw
+then
+ if test ! -L /etc/mtab
+ then
+ rm -f /etc/mtab~ /etc/nologin
+ : > /etc/mtab
+ fi
+ mount -f -o remount /
+ mount -f /proc
+ mount -f /sys
+ test "$devfs" && grep -q '^devfs /dev' /proc/mounts && mount -f "$devfs"
+fi
+
+: exit 0
diff --git a/packages/initscripts/initscripts-1.0/slugos/mountall.sh b/packages/initscripts/initscripts-1.0/slugos/mountall.sh
new file mode 100644
index 0000000000..94ea8217fd
--- /dev/null
+++ b/packages/initscripts/initscripts-1.0/slugos/mountall.sh
@@ -0,0 +1,27 @@
+#
+# mountall.sh Mount all filesystems.
+#
+# Version: @(#)mountall.sh 2.83-2 01-Nov-2001 miquels@cistron.nl
+#
+. /etc/default/rcS
+
+#
+# Mount local filesystems in /etc/fstab. For some reason, people
+# might want to mount "proc" several times, and mount -v complains
+# about this. So we mount "proc" filesystems without -v.
+#
+test "$VERBOSE" != no && echo "Mounting local filesystems..."
+mount -at nonfs,nosmbfs,noncpfs 2>/dev/null
+
+#
+# We might have mounted something over /dev, see if /dev/initctl is there.
+#
+if test ! -p /dev/initctl
+then
+ rm -f /dev/initctl
+ mknod -m 600 /dev/initctl p
+fi
+kill -USR1 1
+
+: exit 0
+
diff --git a/packages/initscripts/initscripts-slugos_1.0.bb b/packages/initscripts/initscripts-slugos_1.0.bb
index 05449958f6..7a4f79c20b 100644
--- a/packages/initscripts/initscripts-slugos_1.0.bb
+++ b/packages/initscripts/initscripts-slugos_1.0.bb
@@ -11,7 +11,7 @@ RCONFLICTS = "initscripts"
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
# a suffix
-PR := "${PR}.5"
+PR := "${PR}.9"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${P}', '${FILE_DIRNAME}/initscripts-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
@@ -19,7 +19,6 @@ PACKAGES = "${PN}"
SRC_URI += "file://alignment.sh"
SRC_URI += "file://domainname.sh"
-SRC_URI += "file://rootopts.patch;patch=1"
SRC_URI += "file://devices.patch;patch=1"
# Without this it is not possible to patch checkroot.sh
diff --git a/packages/libsexy/libsexy_0.1.6.bb b/packages/libsexy/libsexy_0.1.6.bb
new file mode 100644
index 0000000000..5ac5d296fb
--- /dev/null
+++ b/packages/libsexy/libsexy_0.1.6.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Libsexy is a collection of GTK+ widgets that extend the functionality of such standard widgets as GtkEntry and GtkLabel"
+HOMEPAGE = "http://wiki.chipx86.com/wiki/Libsexy"
+AUTHOR = "Christian Hammond <chipx86@chipx86.com>"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>""
+PR = "r0"
+
+DEPENDS = "gtk+ enchant libxml2"
+
+SRC_URI = "http://osiris.chipx86.com/projects/libsexy/releases/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
+
+
diff --git a/packages/meta/slugos-packages.bb b/packages/meta/slugos-packages.bb
index cb525ce2b2..a5a1feeb94 100644
--- a/packages/meta/slugos-packages.bb
+++ b/packages/meta/slugos-packages.bb
@@ -134,7 +134,6 @@ SLUGOS_PACKAGES = "\
samba \
sane-backends \
sed \
- setpwc \
ssmtp \
strace \
streamripper \
@@ -165,6 +164,7 @@ SLUGOS_BROKEN_PACKAGES = "\
icecast \
irssi \
pvrusb2-mci \
+ setpwc \
watchdog \
memtester \
"
diff --git a/packages/setpwc/files/makefile.diff b/packages/setpwc/files/makefile.diff
new file mode 100644
index 0000000000..e129db7b56
--- /dev/null
+++ b/packages/setpwc/files/makefile.diff
@@ -0,0 +1,12 @@
+--- setpwc-1.1/Makefile.orig 2006-02-06 03:25:11.000000000 +0100
++++ setpwc-1.1/Makefile 2006-02-06 03:25:27.000000000 +0100
+@@ -22,9 +22,6 @@
+
+ setpwc: $(OBJS)
+ $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o setpwc
+- strip setpwc
+- #
+- # Oh, blatant plug: http://keetweej.vanheusden.com/wishlist.html
+
+ install: setpwc
+ cp setpwc /usr/bin
diff --git a/packages/setpwc/setpwc_1.1.bb b/packages/setpwc/setpwc_1.1.bb
new file mode 100644
index 0000000000..120ba463bf
--- /dev/null
+++ b/packages/setpwc/setpwc_1.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Set various aspects of Philips (and compatible) WebCams."
+SECTION = "console"
+PRIORITY = "optional"
+MAINTAINER = "NSLU2 Linux <www.nslu2-linux.org>"
+HOMEPAGE = "http://www.vanheusden.com/setpwc/"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.vanheusden.com/setpwc/setpwc-${PV}.tgz \
+ file://makefile.diff;patch=1"
+
+inherit autotools
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/setpwc ${D}${bindir}/setpwc
+}
diff --git a/packages/slugos-init/files/functions b/packages/slugos-init/files/functions
index ef10d65fb2..78dcf816b3 100644
--- a/packages/slugos-init/files/functions
+++ b/packages/slugos-init/files/functions
@@ -26,6 +26,20 @@ machine(){
esac
}
#
+# single_user_ok
+# if the machine is capable of single user interaction return
+# true, else return false. The result of this function is
+# preempted by setting SULOGIN to 'yes' or 'ok' in /etc/default/rcS
+single_user_ok() {
+ # list known good machines in the 'case'
+ test "$SULOGIN" = yes -o "$SULOGIN" = ok ||
+ case "$(machine)" in
+ ixdp*|avila|loft)
+ test "$SULOGIN" != never;;
+ *) return 1;;
+ esac
+}
+#
# load_functions "source"
# load the functions in '/sbin/source' - relies on /sbin/source being
# a shell script and having support for this function.
diff --git a/packages/slugos-init/files/leds b/packages/slugos-init/files/leds
index 227ed78ff4..433467b96f 100644
--- a/packages/slugos-init/files/leds
+++ b/packages/slugos-init/files/leds
@@ -169,7 +169,8 @@ sysled(){
#
# beep {arguments}
# emit a beep
-# does nothing if there is no beep executable
+# does nothing if there is no beep executable, is very
+# quiet in the presence of errors
beep(){
local arg
arg=
@@ -177,7 +178,7 @@ beep(){
if test -x /bin/beep
then
test -c /dev/buzzer && arg="-e /dev/buzzer"
- /bin/beep $arg "$@"
+ /bin/beep $arg "$@" 2>/dev/null
fi
return 0
}
diff --git a/packages/slugos-init/slugos-init_0.10.bb b/packages/slugos-init/slugos-init_0.10.bb
index 7c4c21f521..ed183b9278 100644
--- a/packages/slugos-init/slugos-init_0.10.bb
+++ b/packages/slugos-init/slugos-init_0.10.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r54"
+PR = "r56"
SRC_URI = "file://boot/flash \
file://boot/disk \
diff --git a/packages/sysvinit/sysvinit/slugos/rcS-default b/packages/sysvinit/sysvinit/slugos/rcS-default
index 33917bd557..8bd6656cb5 100644
--- a/packages/sysvinit/sysvinit/slugos/rcS-default
+++ b/packages/sysvinit/sysvinit/slugos/rcS-default
@@ -5,6 +5,9 @@
# Time files in /tmp are kept in days.
TMPTIME=0
# Set to yes if you want sulogin to be spawned on bootup
+# Set to ok if the machine supports SULOGIN, otherwise a
+# boot time failure will be ignored unless the system
+# is known to support a serial port
SULOGIN=no
# Set to no if you want to be able to login over telnet/rlogin
# before system startup is complete (as soon as inetd is started)
@@ -18,5 +21,10 @@ VERBOSE=no
EDITMOTD=no
# Set FSCKFIX to "yes" if you want to add "-y" to the fsck at startup.
FSCKFIX=yes
-# Set TICKADJ to the correct tick value for this specific machine
-#TICKADJ=10000
+# Set DOSWAP to "no" if you do not want all swap to automatically be mounted
+DOSWAP=yes
+# Set ROOTFSCK to "yes" to check the root fs automatically on boot
+# WARNING: fsck for the file system must be installed and must work
+# before enabling this option, if not your system will drop to single
+# user (sulogin) if SULOGIN is set to yes or ok!
+ROOTFSCK=no
diff --git a/packages/sysvinit/sysvinit_2.86.bb b/packages/sysvinit/sysvinit_2.86.bb
index af39d5e740..d15afdfa23 100644
--- a/packages/sysvinit/sysvinit_2.86.bb
+++ b/packages/sysvinit/sysvinit_2.86.bb
@@ -3,7 +3,7 @@ SECTION = "base"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r20"
+PR = "r22"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.