summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/blueprobe/blueprobe-0.17/h2200-fixup.patch11
-rw-r--r--packages/blueprobe/blueprobe_0.17.bb5
-rw-r--r--packages/ethereal/.mtn2git_empty0
-rw-r--r--packages/ethereal/ethereal-native_0.99.0.bb23
-rw-r--r--packages/ethereal/ethereal_0.99.0.bb18
-rw-r--r--packages/ethereal/files/.mtn2git_empty0
-rw-r--r--packages/ethereal/files/use-our-lemon.patch16
-rw-r--r--packages/gpe-aerial/files/iconlist.patch10
-rw-r--r--packages/gpe-aerial/gpe-aerial_0.2.13.bb3
-rw-r--r--packages/libmimedir/files/.mtn2git_empty0
-rw-r--r--packages/libmimedir/files/mimedir-duration.diff77
-rw-r--r--packages/libmimedir/libmimedir_0.3.1.bb5
-rw-r--r--packages/linux/linux-jlime-sh3_2.6.11.bb4
-rw-r--r--packages/python/python-2.4.3-manifest.inc8
-rw-r--r--packages/python/python_2.4.3.bb2
-rw-r--r--packages/qxmp/.mtn2git_empty0
-rw-r--r--packages/qxmp/qxmp_1.0.bb14
-rw-r--r--packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb6
-rw-r--r--packages/wxwidgets/.mtn2git_empty0
-rw-r--r--packages/wxwidgets/wxwidgets_2.6.3.bb17
20 files changed, 209 insertions, 10 deletions
diff --git a/packages/blueprobe/blueprobe-0.17/h2200-fixup.patch b/packages/blueprobe/blueprobe-0.17/h2200-fixup.patch
new file mode 100644
index 0000000000..965bbf405e
--- /dev/null
+++ b/packages/blueprobe/blueprobe-0.17/h2200-fixup.patch
@@ -0,0 +1,11 @@
+--- /tmp/blueprobe.init 2006-05-10 18:38:42.581557352 +0200
++++ blueprobe-0.17/blueprobe.init 2006-05-10 18:38:54.001821208 +0200
+@@ -28,7 +28,7 @@
+ case `module_id` in
+ "HP iPAQ H2200")
+ BLUETOOTH=yes
+- PORT=/dev/tts/3
++ PORT=/dev/ttyS3
+ SPEED=921600
+ PROBE=no
+ RADIO_VER=`h2200_radio_version`
diff --git a/packages/blueprobe/blueprobe_0.17.bb b/packages/blueprobe/blueprobe_0.17.bb
index cdba961b96..433f3dfbd0 100644
--- a/packages/blueprobe/blueprobe_0.17.bb
+++ b/packages/blueprobe/blueprobe_0.17.bb
@@ -2,6 +2,7 @@ SECTION = "base"
LICENSE = "GPL"
inherit gpe
-PR = "r0"
+PR = "r1"
-SRC_URI += "file://hx4700.patch;patch=1"
+SRC_URI += "file://hx4700.patch;patch=1\
+ file://h2200-fixup.patch;patch=1"
diff --git a/packages/ethereal/.mtn2git_empty b/packages/ethereal/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ethereal/.mtn2git_empty
diff --git a/packages/ethereal/ethereal-native_0.99.0.bb b/packages/ethereal/ethereal-native_0.99.0.bb
new file mode 100644
index 0000000000..b5e0c589ed
--- /dev/null
+++ b/packages/ethereal/ethereal-native_0.99.0.bb
@@ -0,0 +1,23 @@
+require ethereal_${PV}.bb
+DEPENDS = "perl-native libpcap-native"
+inherit native
+
+EXTRA_OECONF = "\
+ --enable-ethereal=no \
+ --enable-tethereal=yes \
+ --enable-editcap=no \
+ --enable-dumpcap=no \
+ --enable-capinfos=no \
+ --enable-mergecap=no \
+ --enable-text2pcap=no \
+ --enable-idl2eth=no"
+
+do_stage() {
+ install -m 0755 rdps ${STAGING_BINDIR}/ethereal-rdps
+ install -m 0755 tools/lemon/lemon ${STAGING_BINDIR}/ethereal-lemon
+}
+
+do_install() {
+ :
+}
+
diff --git a/packages/ethereal/ethereal_0.99.0.bb b/packages/ethereal/ethereal_0.99.0.bb
new file mode 100644
index 0000000000..96e121a3a7
--- /dev/null
+++ b/packages/ethereal/ethereal_0.99.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Ethereal is the world's most popular network protocol analyzer"
+HOMEPAGE = "http://www.ethereal.com"
+SECTION = "x11/network"
+LICENSE = "GPL"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+
+DEPENDS = "perl-native ethereal-native gtk+ libpcap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ethereal/ethereal-${PV}.tar.bz2 \
+ file://use-our-lemon.patch;patch=1"
+S = "${WORKDIR}/ethereal-${PV}"
+
+inherit autotools
+
+do_compile_prepend() {
+ ln -sf ${STAGING_BINDIR}/ethereal-rdps rdps
+ ln -sf ${STAGING_BINDIR}/ethereal-lemon tools/lemon/lemon
+}
diff --git a/packages/ethereal/files/.mtn2git_empty b/packages/ethereal/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ethereal/files/.mtn2git_empty
diff --git a/packages/ethereal/files/use-our-lemon.patch b/packages/ethereal/files/use-our-lemon.patch
new file mode 100644
index 0000000000..c2850807db
--- /dev/null
+++ b/packages/ethereal/files/use-our-lemon.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ethereal-0.99.0/tools/Makefile.am~use-our-lemon
++++ ethereal-0.99.0/tools/Makefile.am
+@@ -21,7 +21,7 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-SUBDIRS = lemon
++SUBDIRS =
+
+ PIDL_FILES= \
+ pidl/MANIFEST \
diff --git a/packages/gpe-aerial/files/iconlist.patch b/packages/gpe-aerial/files/iconlist.patch
new file mode 100644
index 0000000000..004e317b90
--- /dev/null
+++ b/packages/gpe-aerial/files/iconlist.patch
@@ -0,0 +1,10 @@
+--- main.c.orig 2006-05-10 21:37:32.000000000 +0200
++++ main.c 2006-05-10 21:37:43.000000000 +0200
+@@ -33,7 +33,6 @@
+ #include <gpe/init.h>
+ #include <gpe/pixmaps.h>
+ #include <gpe/errorbox.h>
+-#include <gpe/gpe-iconlist.h>
+ #include <gpe/tray.h>
+ #include <gpe/popup.h>
+ #include <gpe/spacing.h>
diff --git a/packages/gpe-aerial/gpe-aerial_0.2.13.bb b/packages/gpe-aerial/gpe-aerial_0.2.13.bb
index 987c6535f6..1f79de876b 100644
--- a/packages/gpe-aerial/gpe-aerial_0.2.13.bb
+++ b/packages/gpe-aerial/gpe-aerial_0.2.13.bb
@@ -1,6 +1,6 @@
inherit gpe pkgconfig
-PR = "r0"
+PR = "r1"
DESCRIPTION = "GPE wireless LAN communication applet"
@@ -10,3 +10,4 @@ SECTION = "gpe"
PRIORITY = "optional"
LICENSE = "GPL"
+SRC_URI += "file://iconlist.patch;patch=1;pnum=0" \ No newline at end of file
diff --git a/packages/libmimedir/files/.mtn2git_empty b/packages/libmimedir/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libmimedir/files/.mtn2git_empty
diff --git a/packages/libmimedir/files/mimedir-duration.diff b/packages/libmimedir/files/mimedir-duration.diff
new file mode 100644
index 0000000000..6f991f6aa2
--- /dev/null
+++ b/packages/libmimedir/files/mimedir-duration.diff
@@ -0,0 +1,77 @@
+2006-05-10 Neal H. Walfield <neal@gnu.org>
+
+ * mimedir/mimedir-vcomponent.c
+ (mimedir_vcomponent_get_value_duration): Be more accepting when
+ parsing the DURATION field.
+
+
+--- libmimedir-gnome-0.3.1/mimedir/mimedir-vcomponent.c.orig 2005-11-03 18:04:21.000000000 +0100
++++ libmimedir-gnome-0.3.1/mimedir/mimedir-vcomponent.c 2006-05-10 14:17:24.000000000 +0200
+@@ -951,52 +951,33 @@ mimedir_vcomponent_get_value_duration (M
+
+ s++;
+
+- num = mimedir_vcomponent_parse_number (name, "DURATION", &s, &err);
+- if (err) {
+- g_propagate_error (error, err);
+- return 0;
+- }
+- if (s[0] != 'H') {
+- g_set_error (error, MIMEDIR_ATTRIBUTE_ERROR, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT_STR, "DURATION", name);
+- return 0;
+- }
+- s++;
+- duration += num * SECS_PER_HOUR;
+-
+- if (s[0]) {
++ while (s[0] != '\0') {
+ num = mimedir_vcomponent_parse_number (name, "DURATION", &s, &err);
+ if (err) {
+ g_propagate_error (error, err);
+ return 0;
+ }
+- if (s[0] != 'M') {
+- g_set_error (error, MIMEDIR_ATTRIBUTE_ERROR, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT_STR, "DURATION", name);
+- return 0;
+- }
+- s++;
+- duration += num * SECS_PER_MINUTE;
+- }
+
+- if (s[0]) {
+- num = mimedir_vcomponent_parse_number (name, "DURATION", &s, &err);
+- if (err) {
+- g_propagate_error (error, err);
+- return 0;
+- }
+- if (s[0] != 'S') {
++ switch (s[0]) {
++ case 'H':
++ s++;
++ duration += num * SECS_PER_HOUR;
++ break;
++ case 'M':
++ s++;
++ duration += num * SECS_PER_MINUTE;
++ break;
++ case 'S':
++ s++;
++ duration += num;
++ break;
++ default:
+ g_set_error (error, MIMEDIR_ATTRIBUTE_ERROR, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT_STR, "DURATION", name);
+ return 0;
+ }
+- s++;
+- duration += num;
+ }
+ }
+
+- if (s[0] != '\0') {
+- g_set_error (error, MIMEDIR_ATTRIBUTE_ERROR, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT, MIMEDIR_ATTRIBUTE_ERROR_INVALID_FORMAT_STR, "DURATION", name);
+- return 0;
+- }
+-
+ return neg ? -duration : duration;
+ }
+
diff --git a/packages/libmimedir/libmimedir_0.3.1.bb b/packages/libmimedir/libmimedir_0.3.1.bb
index 21fb6c7d8f..7739b45184 100644
--- a/packages/libmimedir/libmimedir_0.3.1.bb
+++ b/packages/libmimedir/libmimedir_0.3.1.bb
@@ -3,11 +3,12 @@ SECTION = "libs"
PRIORITY = "optional"
LICENSE = "LGPL"
DEPENDS = "intltool-native"
-PR = "r1"
+PR = "r2"
DEFAULT_PREFERENCE = 1
-SRC_URI = "http://www.rittau.org/mimedir/${P}.tar.gz"
+SRC_URI = "http://www.rittau.org/mimedir/${P}.tar.gz \
+ file://mimedir-duration.diff;patch=1"
inherit autotools pkgconfig
diff --git a/packages/linux/linux-jlime-sh3_2.6.11.bb b/packages/linux/linux-jlime-sh3_2.6.11.bb
index b646c1a3b8..a83347bf7b 100644
--- a/packages/linux/linux-jlime-sh3_2.6.11.bb
+++ b/packages/linux/linux-jlime-sh3_2.6.11.bb
@@ -3,6 +3,10 @@ DESCRIPTION = "Linux kernel for Hitachi SH3 based Jornada 6xx"
LICENSE = "GPL"
PR = "r0"
+
+COMPATIBLE_HOST = "sh.*-linux"
+COMPATIBLE_MACHINE = 'jornada6xx'
+
SRC_URI = "http://www.jlime.com/downloads/releases/shrek/kernels/6xx/sources/linuxsh-snapshot-050320-jlimepatched-3.tar.bz2 \
file://defconfig_jlime"
diff --git a/packages/python/python-2.4.3-manifest.inc b/packages/python/python-2.4.3-manifest.inc
index 0178d4e186..abc6278e04 100644
--- a/packages/python/python-2.4.3-manifest.inc
+++ b/packages/python/python-2.4.3-manifest.inc
@@ -1,5 +1,5 @@
########################################################################################################################
-### AUTO-GENERATED by './generate-oe.py' [(C) 2002-2005 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Thu Mar 30 17:39:30 2006
+### AUTO-GENERATED by './generate-oe.py' [(C) 2002-2005 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Wed May 10 13:57:16 2006
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -41,9 +41,9 @@ RDEPENDS_python-datetime="python-core python-codecs"
FILES_python-datetime="${libdir}/python2.4/_strptime.* ${libdir}/python2.4/calendar.* ${libdir}/python2.4/lib-dynload/datetime.so "
DESCRIPTION_python-core="Python Interpreter and core modules (needed!)"
-PR_python-core="ml0"
+PR_python-core="ml1"
RDEPENDS_python-core=""
-FILES_python-core="/usr/lib/python2.4/__future__.* /usr/lib/python2.4/copy.* /usr/lib/python2.4/copy_reg.* /usr/lib/python2.4/ConfigParser.py /usr/lib/python2.4/getopt.* /usr/lib/python2.4/linecache.* /usr/lib/python2.4/new.* /usr/lib/python2.4/os.* /usr/lib/python2.4/posixpath.* /usr/lib/python2.4/warnings.* /usr/lib/python2.4/site.* /usr/lib/python2.4/stat.* /usr/lib/python2.4/UserDict.* /usr/lib/python2.4/lib-dynload/binascii.so /usr/lib/python2.4/lib-dynload/struct.so /usr/lib/python2.4/lib-dynload/time.so /usr/lib/python2.4/lib-dynload/xreadlines.so /usr/lib/python2.4/types.* /usr/bin/python "
+FILES_python-core="/usr/lib/python2.4/__future__.* /usr/lib/python2.4/copy.* /usr/lib/python2.4/copy_reg.* /usr/lib/python2.4/ConfigParser.py /usr/lib/python2.4/getopt.* /usr/lib/python2.4/linecache.* /usr/lib/python2.4/new.* /usr/lib/python2.4/os.* /usr/lib/python2.4/posixpath.* /usr/lib/python2.4/warnings.* /usr/lib/python2.4/site.* /usr/lib/python2.4/stat.* /usr/lib/python2.4/UserDict.* /usr/lib/python2.4/UserList.* /usr/lib/python2.4/UserString.* /usr/lib/python2.4/lib-dynload/binascii.so /usr/lib/python2.4/lib-dynload/struct.so /usr/lib/python2.4/lib-dynload/time.so /usr/lib/python2.4/lib-dynload/xreadlines.so /usr/lib/python2.4/types.* /usr/bin/python "
DESCRIPTION_python-io="Python Low-Level I/O"
PR_python-io="ml0"
@@ -195,7 +195,7 @@ PR_python-unittest="ml0"
RDEPENDS_python-unittest="python-core python-stringold python-lang"
FILES_python-unittest="${libdir}/python2.4/unittest.* "
-DESCRIPTION_python-stringold="Python Deprecated String APIs"
+DESCRIPTION_python-stringold="Python String APIs [deprecated]"
PR_python-stringold="ml0"
RDEPENDS_python-stringold="python-core python-re"
FILES_python-stringold="${libdir}/python2.4/lib-dynload/strop.so ${libdir}/python2.4/string.* "
diff --git a/packages/python/python_2.4.3.bb b/packages/python/python_2.4.3.bb
index 30ce73abe2..64e927c871 100644
--- a/packages/python/python_2.4.3.bb
+++ b/packages/python/python_2.4.3.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml3"
+PR = "ml4"
PYTHON_MAJMIN = "2.4"
diff --git a/packages/qxmp/.mtn2git_empty b/packages/qxmp/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qxmp/.mtn2git_empty
diff --git a/packages/qxmp/qxmp_1.0.bb b/packages/qxmp/qxmp_1.0.bb
new file mode 100644
index 0000000000..e0a1acab21
--- /dev/null
+++ b/packages/qxmp/qxmp_1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Qxmp is a Qt4 media player based on MPlayer"
+LICENSE = "GPL"
+SECTION = "x11/multimedia"
+HOMEPAGE = "http://www.xm1math.net/qxmp/index.html"
+RDEPENDS = "mplayer"
+
+SRC_URI = "http://www.xm1math.net/qxmp/qxmp-${PV}.tar.bz2"
+
+inherit qmake qt4x11
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 qxmp ${D}${bindir}
+}
diff --git a/packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb b/packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb
new file mode 100644
index 0000000000..56f86e6923
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb
@@ -0,0 +1,6 @@
+include sylpheed-claws-extra-plugins.inc
+
+DEPENDS_append = " db"
+
+S = ${WORKDIR}/sylpheed-claws-extra-plugins-${PV}/maildir-0.22
+
diff --git a/packages/wxwidgets/.mtn2git_empty b/packages/wxwidgets/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wxwidgets/.mtn2git_empty
diff --git a/packages/wxwidgets/wxwidgets_2.6.3.bb b/packages/wxwidgets/wxwidgets_2.6.3.bb
new file mode 100644
index 0000000000..0cd88334b3
--- /dev/null
+++ b/packages/wxwidgets/wxwidgets_2.6.3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "wxWidgets is a cross platform application framework utilizing native widgets."
+HOMEPAGE = "http://www.wxwidgets.org"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wxwindows/wxWidgets-${PV}.tar.gz"
+S = "${WORKDIR}/wxWidgets-${PV}"
+
+inherit autotools pkgconfig
+
+do_configure() {
+ oe_runconf
+}
+
+#FIXME add sane packaging