summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/qmake/qmake2-native_2.10a.bb4
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/.mtn2git_empty (renamed from packages/qt/qt4-x11-free-4.3.0/.mtn2git_empty)0
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0001-cross-compile.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0001-cross-compile.patch)31
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0002-fix-resinit-declaration.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0002-fix-resinit-declaration.patch)0
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0003-no-tools.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0003-no-tools.patch)0
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0004-no-qmake.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0004-no-qmake.patch)0
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0005-fix-mkspecs.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0005-fix-mkspecs.patch)0
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0006-freetype-host-includes.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0006-freetype-host-includes.patch)0
-rw-r--r--packages/qt/qt4-x11-free-4.3.2/0007-openssl-host-includes.patch (renamed from packages/qt/qt4-x11-free-4.3.0/0007-openssl-host-includes.patch)0
-rw-r--r--packages/qt/qt4-x11-free_4.3.2.bb (renamed from packages/qt/qt4-x11-free_4.3.0.bb)0
-rw-r--r--packages/qte/qtopia-core_4.3.2.bb (renamed from packages/qte/qtopia-core_4.3.1.bb)2
-rw-r--r--packages/uicmoc/uicmoc4-native_4.3.2.bb60
-rw-r--r--packages/webkit/webkit-qt.inc6
-rw-r--r--packages/webkit/webkit-qt_svn.bb2
-rw-r--r--packages/webkit/webkit-qtopia_svn.bb3
15 files changed, 90 insertions, 18 deletions
diff --git a/packages/qmake/qmake2-native_2.10a.bb b/packages/qmake/qmake2-native_2.10a.bb
index 55282e562c..84df0ef732 100644
--- a/packages/qmake/qmake2-native_2.10a.bb
+++ b/packages/qmake/qmake2-native_2.10a.bb
@@ -3,9 +3,9 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
-QTVER = "qtopia-core-opensource-src-4.3.1"
+QTVER = "qtopia-core-opensource-src-4.3.2"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
file://0001-fix-mkspecs.patch;patch=1 \
diff --git a/packages/qt/qt4-x11-free-4.3.0/.mtn2git_empty b/packages/qt/qt4-x11-free-4.3.2/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/qt/qt4-x11-free-4.3.0/.mtn2git_empty
+++ b/packages/qt/qt4-x11-free-4.3.2/.mtn2git_empty
diff --git a/packages/qt/qt4-x11-free-4.3.0/0001-cross-compile.patch b/packages/qt/qt4-x11-free-4.3.2/0001-cross-compile.patch
index 42f7b5575c..6e2b8e755e 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0001-cross-compile.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0001-cross-compile.patch
@@ -7,11 +7,11 @@ Subject: [PATCH] cross compile
configure | 137 ++----------------------------------------------------------
1 files changed, 5 insertions(+), 132 deletions(-)
-diff --git a/configure b/configure
-index 6b3ccd2..b3c2a52 100755
---- a/configure
-+++ b/configure
-@@ -733,7 +733,7 @@ while [ "$#" -gt 0 ]; do
+Index: qt-x11-opensource-src-4.3.2/configure
+===================================================================
+--- qt-x11-opensource-src-4.3.2.orig/configure 2007-10-01 15:06:03.000000000 +0200
++++ qt-x11-opensource-src-4.3.2/configure 2007-10-23 09:32:25.000000000 +0200
+@@ -735,7 +735,7 @@
UNKNOWN_ARG=yes
fi
;;
@@ -20,7 +20,7 @@ index 6b3ccd2..b3c2a52 100755
VAR=`echo $1 | sed "s,^-\(.*\),\1,"`
shift
VAL="$1"
-@@ -1109,6 +1109,9 @@ while [ "$#" -gt 0 ]; do
+@@ -1124,6 +1124,9 @@
xplatform)
XPLATFORM="$VAL"
;;
@@ -30,7 +30,7 @@ index 6b3ccd2..b3c2a52 100755
debug-and-release)
if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
CFG_DEBUG_RELEASE="$VAL"
-@@ -2092,137 +2095,7 @@ if [ "$OPT_VERBOSE" = "yes" ]; then
+@@ -2119,149 +2122,7 @@
echo "Determining system architecture... ($UNAME_SYSTEM:$UNAME_RELEASE:$UNAME_MACHINE)"
fi
@@ -116,7 +116,7 @@ index 6b3ccd2..b3c2a52 100755
- ARCH=i386
- ;;
- *:*:x86_64|*:*:amd64)
-- if [ "$PLATFORM" = "linux-g++-32" ]; then
+- if [ "$PLATFORM" = "linux-g++-32" -o "$PLATFORM" = "linux-icc-32" ]; then
- if [ "$OPT_VERBOSE" = "yes" ]; then
- echo " 32 bit on 64-bit AMD 80x86 (i386)"
- fi
@@ -146,6 +146,18 @@ index 6b3ccd2..b3c2a52 100755
- fi
- ARCH=s390
- ;;
+- *:*:arm*)
+- if [ "$OPT_VERBOSE" = "yes" ]; then
+- echo " ARM (arm)"
+- fi
+- ARCH=arm
+- ;;
+- Linux:*:sparc*)
+- if [ "$OPT_VERBOSE" = "yes" ]; then
+- echo " Linux on SPARC"
+- fi
+- ARCH=sparc
+- ;;
- *:*:*)
- if [ "$OPT_VERBOSE" = "yes" ]; then
- echo " Trying '$UNAME_MACHINE'..."
@@ -169,6 +181,3 @@ index 6b3ccd2..b3c2a52 100755
if [ "$OPT_VERBOSE" = "yes" ]; then
echo "System architecture: '$ARCH'"
---
-1.5.0.7
-
diff --git a/packages/qt/qt4-x11-free-4.3.0/0002-fix-resinit-declaration.patch b/packages/qt/qt4-x11-free-4.3.2/0002-fix-resinit-declaration.patch
index e479a64a2b..e479a64a2b 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0002-fix-resinit-declaration.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0002-fix-resinit-declaration.patch
diff --git a/packages/qt/qt4-x11-free-4.3.0/0003-no-tools.patch b/packages/qt/qt4-x11-free-4.3.2/0003-no-tools.patch
index 5412c90377..5412c90377 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0003-no-tools.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0003-no-tools.patch
diff --git a/packages/qt/qt4-x11-free-4.3.0/0004-no-qmake.patch b/packages/qt/qt4-x11-free-4.3.2/0004-no-qmake.patch
index 359f6df9d5..359f6df9d5 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0004-no-qmake.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0004-no-qmake.patch
diff --git a/packages/qt/qt4-x11-free-4.3.0/0005-fix-mkspecs.patch b/packages/qt/qt4-x11-free-4.3.2/0005-fix-mkspecs.patch
index 93692699dc..93692699dc 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0005-fix-mkspecs.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0005-fix-mkspecs.patch
diff --git a/packages/qt/qt4-x11-free-4.3.0/0006-freetype-host-includes.patch b/packages/qt/qt4-x11-free-4.3.2/0006-freetype-host-includes.patch
index cc8e115fee..cc8e115fee 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0006-freetype-host-includes.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0006-freetype-host-includes.patch
diff --git a/packages/qt/qt4-x11-free-4.3.0/0007-openssl-host-includes.patch b/packages/qt/qt4-x11-free-4.3.2/0007-openssl-host-includes.patch
index 35b71d9694..35b71d9694 100644
--- a/packages/qt/qt4-x11-free-4.3.0/0007-openssl-host-includes.patch
+++ b/packages/qt/qt4-x11-free-4.3.2/0007-openssl-host-includes.patch
diff --git a/packages/qt/qt4-x11-free_4.3.0.bb b/packages/qt/qt4-x11-free_4.3.2.bb
index a097c4e9ca..a097c4e9ca 100644
--- a/packages/qt/qt4-x11-free_4.3.0.bb
+++ b/packages/qt/qt4-x11-free_4.3.2.bb
diff --git a/packages/qte/qtopia-core_4.3.1.bb b/packages/qte/qtopia-core_4.3.2.bb
index 73cfb7f6da..c486ba164f 100644
--- a/packages/qte/qtopia-core_4.3.1.bb
+++ b/packages/qte/qtopia-core_4.3.2.bb
@@ -5,7 +5,7 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
DEPENDS = "freetype tslib"
-PR = "r1"
+PR = "r0"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
file://linux-oe-qmake.conf"
diff --git a/packages/uicmoc/uicmoc4-native_4.3.2.bb b/packages/uicmoc/uicmoc4-native_4.3.2.bb
new file mode 100644
index 0000000000..df39a494b2
--- /dev/null
+++ b/packages/uicmoc/uicmoc4-native_4.3.2.bb
@@ -0,0 +1,60 @@
+DESCRIPTION = "User-Interface-, Meta-Object-, and Resource Compiler for Qt/[X11|Mac|Embedded] version 4.x"
+SECTION = "libs"
+HOMEPAGE = "http://www.trolltech.com"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz"
+S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "-prefix ${STAGING_DIR}/${BUILD_SYS}/qt4 \
+ -qt-libjpeg -qt-gif -system-zlib \
+ -no-nis -no-cups -no-exceptions \
+ -no-accessibility -no-libjpeg \
+ -no-nas-sound -no-sm \
+ -no-xshape -no-xinerama \
+ -no-xcursor -no-xrandr \
+ -no-xrender -no-fontconfig \
+ -no-tablet -no-xkb \
+ -no-libpng \
+ -verbose -release -fast -static \
+ -qt3support "
+# yank default -e
+EXTRA_OEMAKE = " "
+
+do_configure() {
+ sed -i 's:^QT += xml qt3support$:QT += xml qt3support network:' "${S}"/src/tools/uic3/uic3.pro
+ echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
+}
+
+TOBUILD = "\
+ src/tools/moc \
+ src/corelib \
+ src/sql \
+ src/qt3support \
+ src/xml \
+ src/tools/uic \
+ src/tools/rcc \
+ src/network \
+ src/gui \
+ src/tools/uic3 \
+"
+
+do_compile() {
+ unset CC CXX CFLAGS LFLAGS CXXFLAGS CPPFLAGS
+ for i in ${TOBUILD}; do
+ cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
+ done
+}
+
+do_stage() {
+ install -m 0755 bin/moc ${STAGING_BINDIR}/moc4
+ install -m 0755 bin/uic ${STAGING_BINDIR}/uic4
+ install -m 0755 bin/uic3 ${STAGING_BINDIR}/uic34
+ install -m 0755 bin/rcc ${STAGING_BINDIR}/rcc4
+ install -d ${STAGING_DIR}/${BUILD_SYS}/qt4/
+ install -m 0644 tools/porting/src/q3porting.xml ${STAGING_DIR}/${BUILD_SYS}/qt4/
+}
diff --git a/packages/webkit/webkit-qt.inc b/packages/webkit/webkit-qt.inc
index bba8d83cce..cb9c1f7943 100644
--- a/packages/webkit/webkit-qt.inc
+++ b/packages/webkit/webkit-qt.inc
@@ -1,9 +1,9 @@
WEBKIT_PORT = "qt"
WEBKIT_EXTRA_OPTIONS = ""
-PACKAGES =+ "webkit-qtlauncher-dbg webkit-qtlauncher"
+PACKAGES =+ "${PN}launcher-dbg ${PN}launcher"
-FILES_webkit-qtlauncher = "${bindir}/QtLauncher"
-FILES_webkit-qtlauncher-dbg = "${bindir}/.debug/*"
+FILES_${PN}launcher = "${bindir}/QtLauncher"
+FILES_${PN}launcher-dbg = "${bindir}/.debug/*"
require webkit.inc
diff --git a/packages/webkit/webkit-qt_svn.bb b/packages/webkit/webkit-qt_svn.bb
index 75b36a4a58..e681e7a41b 100644
--- a/packages/webkit/webkit-qt_svn.bb
+++ b/packages/webkit/webkit-qt_svn.bb
@@ -1,2 +1,4 @@
require webkit-qt.inc
inherit qt4x11
+
+PR = "r1"
diff --git a/packages/webkit/webkit-qtopia_svn.bb b/packages/webkit/webkit-qtopia_svn.bb
index cfd96c8956..706f0f1cd1 100644
--- a/packages/webkit/webkit-qtopia_svn.bb
+++ b/packages/webkit/webkit-qtopia_svn.bb
@@ -1,3 +1,4 @@
-BROKEN="1"
require webkit-qt.inc
inherit qtopia4core
+
+PR = "r1"