summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/handhelds-pxa-2.6_cvs.bb4
-rw-r--r--packages/matchbox-panel/matchbox-panel.inc1
-rw-r--r--packages/tslib/tslib/h4000/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/h4000/tslib.sh19
4 files changed, 22 insertions, 2 deletions
diff --git a/packages/linux/handhelds-pxa-2.6_cvs.bb b/packages/linux/handhelds-pxa-2.6_cvs.bb
index e00598d937..7dfcb4d237 100644
--- a/packages/linux/handhelds-pxa-2.6_cvs.bb
+++ b/packages/linux/handhelds-pxa-2.6_cvs.bb
@@ -3,10 +3,10 @@ DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
MAINTAINER = "Greg Gilbert <greg@treke.net>"
LICENSE = "GPL"
PV = "${K_MAJOR}.${K_MINOR}.${K_MICRO}-hh${HHV}+cvs${SRCDATE}"
-PR = "r2"
+PR = "r3"
#
COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = '(h3900|h5xxx|h2200|ipaq-pxa270|htcuniversal)'
+COMPATIBLE_MACHINE = '(h3900|h5xxx|h2200|h4000|ipaq-pxa270|htcuniversal)'
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
diff --git a/packages/matchbox-panel/matchbox-panel.inc b/packages/matchbox-panel/matchbox-panel.inc
index f82b66a0e9..16f471356a 100644
--- a/packages/matchbox-panel/matchbox-panel.inc
+++ b/packages/matchbox-panel/matchbox-panel.inc
@@ -11,6 +11,7 @@ EXTRA_OECONF = " --enable-startup-notification --enable-dnotify "
EXTRA_OECONF_append_h3600 = " --enable-small-icons "
EXTRA_OECONF_append_h3900 = " --enable-small-icons "
EXTRA_OECONF_append_h2200 = " --enable-small-icons "
+EXTRA_OECONF_append_h4000 = " --enable-small-icons "
EXTRA_OECONF_append_collie = " --enable-small-icons "
EXTRA_OECONF_append_poodle = " --enable-small-icons "
EXTRA_OECONF_append_mnci = " --enable-small-icons "
diff --git a/packages/tslib/tslib/h4000/.mtn2git_empty b/packages/tslib/tslib/h4000/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/h4000/.mtn2git_empty
diff --git a/packages/tslib/tslib/h4000/tslib.sh b/packages/tslib/tslib/h4000/tslib.sh
new file mode 100644
index 0000000000..0de3534a51
--- /dev/null
+++ b/packages/tslib/tslib/h4000/tslib.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+module_id() {
+ awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
+}
+
+case `uname -r` in
+2.4*)
+ TSLIB_TSDEVICE=/dev/touchscreen/0raw
+ TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600-2.4
+ ;;
+*)
+ TSLIB_TSDEVICE=`detect-stylus --device`
+ TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
+ ;;
+esac
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
+