summaryrefslogtreecommitdiff
path: root/packages/xserver-common
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xserver-common')
-rw-r--r--packages/xserver-common/.mtn2git_empty0
-rw-r--r--packages/xserver-common/files/.mtn2git_empty0
-rw-r--r--packages/xserver-common/files/calibrate_zaurusd.patch12
-rw-r--r--packages/xserver-common/files/poodle-xmodmap-2.6.patch42
-rw-r--r--packages/xserver-common/files/setDPI.sh92
-rw-r--r--packages/xserver-common/files/w100.patch12
-rw-r--r--packages/xserver-common/xserver-common_1.10.bb20
-rw-r--r--packages/xserver-common/xserver-common_1.3.bb12
-rw-r--r--packages/xserver-common/xserver-common_1.8.bb18
-rw-r--r--packages/xserver-common/xserver-common_1.9.bb19
10 files changed, 227 insertions, 0 deletions
diff --git a/packages/xserver-common/.mtn2git_empty b/packages/xserver-common/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xserver-common/.mtn2git_empty
diff --git a/packages/xserver-common/files/.mtn2git_empty b/packages/xserver-common/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xserver-common/files/.mtn2git_empty
diff --git a/packages/xserver-common/files/calibrate_zaurusd.patch b/packages/xserver-common/files/calibrate_zaurusd.patch
new file mode 100644
index 0000000000..6a7e3b02b7
--- /dev/null
+++ b/packages/xserver-common/files/calibrate_zaurusd.patch
@@ -0,0 +1,12 @@
+--- xserver-common-1.8/X11/Xinit.d/30xTs_Calibrate.orig 2006-04-09 15:12:16.167950472 +0200
++++ xserver-common-1.8/X11/Xinit.d/30xTs_Calibrate 2006-04-09 15:14:51.511334688 +0200
+@@ -2,4 +2,9 @@
+
+ if [ ! -f /etc/pointercal ]; then
+ /usr/bin/run-calibrate.sh
++
++ if [ -x /etc/init.d/zaurusd ]; then
++ /etc/init.d/zaurusd stop
++ /etc/init.d/zaurusd start
++ fi
+ fi
diff --git a/packages/xserver-common/files/poodle-xmodmap-2.6.patch b/packages/xserver-common/files/poodle-xmodmap-2.6.patch
new file mode 100644
index 0000000000..73cf3f6ffb
--- /dev/null
+++ b/packages/xserver-common/files/poodle-xmodmap-2.6.patch
@@ -0,0 +1,42 @@
+diff -Nur xserver-common-1.8.orig/X11/Xinit.d/12keymap xserver-common-1.8/X11/Xinit.d/12keymap
+--- xserver-common-1.8.orig/X11/Xinit.d/12keymap 2006-05-17 12:02:52.645201000 +0200
++++ xserver-common-1.8/X11/Xinit.d/12keymap 2006-05-17 12:03:49.401573648 +0200
+@@ -9,6 +9,9 @@
+ "SHARP Akita" | "SHARP Borzoi" | "SHARP Spitz")
+ xmodmap - < /etc/X11/slcXXXX.xmodmap
+ ;;
++ "SHARP Poodle")
++ xmodmap - < /etc/X11/poodle.xmodmap
++ ;;
+ "Sharp-Collie")
+ xmodmap - < /etc/X11/collie.xmodmap
+ ;;
+diff -Nur xserver-common-1.8.orig/X11/poodle.xmodmap xserver-common-1.8/X11/poodle.xmodmap
+--- xserver-common-1.8.orig/X11/poodle.xmodmap 1970-01-01 01:00:00.000000000 +0100
++++ xserver-common-1.8/X11/poodle.xmodmap 2006-05-18 13:42:45.711264920 +0200
+@@ -0,0 +1,25 @@
++keycode 37 = Control_L
++keycode 64 = Alt_L
++
++
++keycode 50 = Shift_L
++keycode 62 = Shift_R
++keycode 75 = Mode_switch
++
++
++
++clear control
++clear shift
++clear lock
++clear mod4
++clear mod1
++
++add control = Control_L
++add shift = Shift_L Shift_R
++add lock = Caps_Lock
++
++! This is AltGr
++add mod4 = Mode_switch
++
++add mod1 = Alt_L
++
diff --git a/packages/xserver-common/files/setDPI.sh b/packages/xserver-common/files/setDPI.sh
new file mode 100644
index 0000000000..04a2edd6c6
--- /dev/null
+++ b/packages/xserver-common/files/setDPI.sh
@@ -0,0 +1,92 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: setDPI.sh
+# Date: 09-Apr-06
+
+# This script configures Xft.dpi dependent on your screens DPI. This insures that the same font-size
+# setting of 7 can be used on all machines.
+
+
+XDEFAULTS="/etc/X11/Xdefaults"
+
+
+
+set_dpi() {
+
+ CURRENT_SETTING="`cat ${XDEFAULTS} | sed -n "/Xft.dpi\:/s/.*\:\(.*\)/\1/p" | sed -n "s/\ //p"`"
+
+ if test "$CURRENT_SETTING" != "$1"
+ then
+ echo "Using Xft.dpi of $SET_SCREEN_DPI for your $SCREEN_DPI DPI screen"
+
+ if grep -q "Xft.dpi" "$XDEFAULTS"
+ then
+ cat "${XDEFAULTS}" | sed "s/^Xft.dpi\:.*/Xft.dpi\: $SET_SCREEN_DPI/" > "${XDEFAULTS}_"
+ mv "${XDEFAULTS}_" "${XDEFAULTS}"
+ else
+ echo -e "Xft.dpi: $SET_SCREEN_DPI\n" >> "$XDEFAULTS"
+ fi
+ else
+ echo "Your $SCREEN_DPI DPI screen is already configured."
+ fi
+}
+
+set_rxvt_font() {
+
+ CURRENT_SETTING="`cat ${XDEFAULTS} | sed -n "/Rxvt\*font/s/\(.*\pixelsize=\)\(.*\)/\2/p"`"
+
+ if test "$1" -gt 100
+ then
+
+ # Configure the rxvt font-size for your screen here:
+ test "$1" -gt 180 -a "$1" -lt "221" && RXVT_FONT_SIZE=16
+
+ if test -z "$RXVT_FONT_SIZE"
+ then
+ echo "WARNING: No rxvt font-size configured for a $SCREEN_DPI DPI screen!"
+ echo "Defaulting to size 9"
+ RXVT_FONT_SIZE=9
+ fi
+
+ if test "$CURRENT_SETTING" != "$RXVT_FONT_SIZE"
+ then
+ echo "Using a rxvt font-size of $RXVT_FONT_SIZE"
+ cat ${XDEFAULTS} | sed "/Rxvt\*font/s/\(.*\pixelsize\)\(=*.*\)/\1=$RXVT_FONT_SIZE/" > ${XDEFAULTS}_
+ mv ${XDEFAULTS}_ ${XDEFAULTS}
+ else
+ echo "The rxvt font-size is already configured"
+ fi
+ fi
+}
+
+if test -z "$DISPLAY"
+then
+ echo "DISPLAY is not set, aborting..."
+ exit 0
+fi
+
+SCREEN_DPI="`/usr/bin/xdpyinfo | grep "dots per inch" | awk '{print $2}'| sed -n "s/\(.*\)x\(.*\)/\2/p"`"
+
+if test -z "$SCREEN_DPI"
+then
+ echo "WARNING: Couldn't read your screens DPI, defaulting to 100"
+ SCREEN_DPI=100
+fi
+
+# Configure your screen here:
+test "$SCREEN_DPI" -gt 180 -a "$SCREEN_DPI" -lt "221" && SET_SCREEN_DPI=160
+test "$SCREEN_DPI" -gt 90 -a "$SCREEN_DPI" -lt "121" && SET_SCREEN_DPI=100
+
+
+if test -z "$SET_SCREEN_DPI"
+then
+ echo "WARNING: No default configuration found for your $SCREEN_DPI DPI screen!"
+ echo "Using 100 DPI"
+ SET_SCREEN_DPI=100
+fi
+
+set_dpi "$SET_SCREEN_DPI"
+set_rxvt_font "$SCREEN_DPI"
diff --git a/packages/xserver-common/files/w100.patch b/packages/xserver-common/files/w100.patch
new file mode 100644
index 0000000000..ca908850e2
--- /dev/null
+++ b/packages/xserver-common/files/w100.patch
@@ -0,0 +1,12 @@
+--- xserver-common-1.10/X11/Xserver.orig 2006-09-02 13:54:30.000000000 +0200
++++ xserver-common-1.10/X11/Xserver 2006-09-02 14:00:22.000000000 +0200
+@@ -14,6 +14,9 @@
+ if [ -f /usr/bin/Xomap ]; then
+ XSERVER=Xomap
+ fi
++if [ -f /usr/bin/Xw100 ]; then
++ XSERVER=Xw100
++fi
+
+ . /etc/profile
+
diff --git a/packages/xserver-common/xserver-common_1.10.bb b/packages/xserver-common/xserver-common_1.10.bb
new file mode 100644
index 0000000000..64c223f109
--- /dev/null
+++ b/packages/xserver-common/xserver-common_1.10.bb
@@ -0,0 +1,20 @@
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
+PR = "r2"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh \
+ file://calibrate_zaurusd.patch;patch=1 \
+ file://w100.patch;patch=1 \
+ file://poodle-xmodmap-2.6.patch;patch=1"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}
diff --git a/packages/xserver-common/xserver-common_1.3.bb b/packages/xserver-common/xserver-common_1.3.bb
new file mode 100644
index 0000000000..ea3fab6654
--- /dev/null
+++ b/packages/xserver-common/xserver-common_1.3.bb
@@ -0,0 +1,12 @@
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
+PR = "r1"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
diff --git a/packages/xserver-common/xserver-common_1.8.bb b/packages/xserver-common/xserver-common_1.8.bb
new file mode 100644
index 0000000000..b7b3f554f3
--- /dev/null
+++ b/packages/xserver-common/xserver-common_1.8.bb
@@ -0,0 +1,18 @@
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
+PR = "r2"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh \
+ file://calibrate_zaurusd.patch;patch=1"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}
diff --git a/packages/xserver-common/xserver-common_1.9.bb b/packages/xserver-common/xserver-common_1.9.bb
new file mode 100644
index 0000000000..de81537f99
--- /dev/null
+++ b/packages/xserver-common/xserver-common_1.9.bb
@@ -0,0 +1,19 @@
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
+PR = "r1"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh \
+ file://calibrate_zaurusd.patch;patch=1 \
+ file://poodle-xmodmap-2.6.patch;patch=1"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}