summaryrefslogtreecommitdiff
path: root/packages/xlibs/libx11
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xlibs/libx11')
-rw-r--r--packages/xlibs/libx11/.mtn2git_empty0
-rw-r--r--packages/xlibs/libx11/autofoo.patch22
-rw-r--r--packages/xlibs/libx11/errordb-keysymdb-path-fix.patch22
-rw-r--r--packages/xlibs/libx11/fix-utf8-wrong-define.patch16
-rw-r--r--packages/xlibs/libx11/xim.patch55
5 files changed, 115 insertions, 0 deletions
diff --git a/packages/xlibs/libx11/.mtn2git_empty b/packages/xlibs/libx11/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xlibs/libx11/.mtn2git_empty
diff --git a/packages/xlibs/libx11/autofoo.patch b/packages/xlibs/libx11/autofoo.patch
new file mode 100644
index 0000000000..8bdba09768
--- /dev/null
+++ b/packages/xlibs/libx11/autofoo.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libX11-6.2.1/configure.ac~autofoo
++++ libX11-6.2.1/configure.ac
+@@ -7,12 +7,12 @@
+ [jg@freedesktop.org],
+ libX11)
+ AC_CONFIG_SRCDIR([Makefile.am])
+-AM_INIT_AUTOMAKE([dist-bzip2])
++AC_CONFIG_AUX_DIR(.)
+
++AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_MAINTAINER_MODE
+
+ AM_CONFIG_HEADER([src/config.h])
+-AC_CONFIG_AUX_DIR(.)
+
+ # Checks for programs.
+ AC_PROG_LIBTOOL
diff --git a/packages/xlibs/libx11/errordb-keysymdb-path-fix.patch b/packages/xlibs/libx11/errordb-keysymdb-path-fix.patch
new file mode 100644
index 0000000000..f43d38065e
--- /dev/null
+++ b/packages/xlibs/libx11/errordb-keysymdb-path-fix.patch
@@ -0,0 +1,22 @@
+--- X11/src/ErrDes.c.orig 2005-09-03 16:15:48 +0200
++++ X11/src/ErrDes.c 2005-09-03 16:16:03 +0200
+@@ -56,7 +56,7 @@
+ #include <stdio.h>
+
+ #ifndef ERRORDB
+-#define ERRORDB "/usr/lib/X11/XErrorDB"
++#define ERRORDB "/usr/share/X11/XErrorDB"
+ #endif
+
+ /*
+--- X11/src/StrKeysym.c.orig 2005-09-03 16:41:18 +0200
++++ X11/src/StrKeysym.c 2005-09-03 16:41:33 +0200
+@@ -36,7 +36,7 @@
+ #include "Key.h"
+
+ #ifndef KEYSYMDB
+-#define KEYSYMDB "/usr/lib/X11/XKeysymDB"
++#define KEYSYMDB "/usr/share/X11/XKeysymDB"
+ #endif
+
+ static Bool initialized;
diff --git a/packages/xlibs/libx11/fix-utf8-wrong-define.patch b/packages/xlibs/libx11/fix-utf8-wrong-define.patch
new file mode 100644
index 0000000000..dca88fba92
--- /dev/null
+++ b/packages/xlibs/libx11/fix-utf8-wrong-define.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libX11-6.2.1/include/X11/Xlib.h~fix-utf8-wrong-define
++++ libX11-6.2.1/include/X11/Xlib.h
+@@ -100,7 +100,7 @@
+
+ /* API mentioning "UTF8" or "utf8" is an XFree86 extension, introduced in
+ November 2000. Its presence is indicated through the following macro. */
+-#define X_HAVE_UTF8_STRING 1
++#undef X_HAVE_UTF8_STRING
+
+ typedef char *XPointer;
+
diff --git a/packages/xlibs/libx11/xim.patch b/packages/xlibs/libx11/xim.patch
new file mode 100644
index 0000000000..0eab197a80
--- /dev/null
+++ b/packages/xlibs/libx11/xim.patch
@@ -0,0 +1,55 @@
+--- libX11-6.2.1/src/X18NCMSstubs.c 2003-12-04 22:47:47.000000000 +0000
++++ libX11-6.2.1/src/X18NCMSstubs.c-new 2005-12-09 12:09:03.000000000 +0000
+@@ -90,6 +90,52 @@
+ return;
+ }
+
++XIM
++XOpenIM (
++ Display* display,
++ struct _XrmHashBucketRec* rdb,
++ char* res_name,
++ char* res_class)
++{
++ return (XIM) NULL;
++}
++
++Status
++XCloseIM ( XIM im )
++{
++ return NULL;
++}
++
++XIC
++XCreateIC ( XIM im, ...)
++{
++ return NULL;
++}
++
++void
++XDestroyIC ( XIC ic )
++{
++ return;
++}
++
++int
++XmbLookupString (
++ XIC ic,
++ XKeyPressedEvent* ev,
++ char* buffer,
++ int nbytes,
++ KeySym* keysym,
++ Status* status)
++{
++ return XLookupNone;
++}
++
++char *
++XGetICValues( XIC ic, ...)
++{
++ return (char *) NULL;
++}
++
+ XPointer
+ _XimGetLocaleCode ( _Xconst char* encoding_name )
+ {