summaryrefslogtreecommitdiff
path: root/packages/xfce4-panel/xfce4-panel_4.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xfce4-panel/xfce4-panel_4.2.0.bb')
-rw-r--r--packages/xfce4-panel/xfce4-panel_4.2.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/xfce4-panel/xfce4-panel_4.2.0.bb b/packages/xfce4-panel/xfce4-panel_4.2.0.bb
index e69de29bb2..4950da6f68 100644
--- a/packages/xfce4-panel/xfce4-panel_4.2.0.bb
+++ b/packages/xfce4-panel/xfce4-panel_4.2.0.bb
@@ -0,0 +1,25 @@
+# xfce4-panel OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="XFCE4 Panel"
+SECTION = "x11"
+DEPENDS="startup-notification x11 libxfcegui4 libxfce4mcs xfce-mcs-manager libxml2"
+inherit pkgconfig xfce
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+HEADERS="controls.h global.h icons.h main.h panel.h item.h \
+ item_dialog.h plugins.h xfce_support.h xfce.h"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xfce4/panel
+
+ for file in ${HEADERS}; do
+ install -m 644 ${S}/panel/$file ${STAGING_INCDIR}/xfce4/panel/$file
+ done
+}