summaryrefslogtreecommitdiff
path: root/packages/xcomposite/xcomposite_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xcomposite/xcomposite_1.0.1.bb')
-rw-r--r--packages/xcomposite/xcomposite_1.0.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/xcomposite/xcomposite_1.0.1.bb b/packages/xcomposite/xcomposite_1.0.1.bb
index e69de29bb2..54af50581b 100644
--- a/packages/xcomposite/xcomposite_1.0.1.bb
+++ b/packages/xcomposite/xcomposite_1.0.1.bb
@@ -0,0 +1,18 @@
+SECTION = "x11/libs"
+DEPENDS = "x11 compositeext xextensions libxfixes"
+DESCRIPTION = "X Composite extension library."
+PR = "r1"
+
+SRC_URI = "${XLIBS_MIRROR}/libXcomposite-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/libXcomposite-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}