summaryrefslogtreecommitdiff
path: root/packages/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/webkit/webkit-gtk_svn.bb')
-rw-r--r--packages/webkit/webkit-gtk_svn.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/packages/webkit/webkit-gtk_svn.bb b/packages/webkit/webkit-gtk_svn.bb
deleted file mode 100644
index 98926727fe..0000000000
--- a/packages/webkit/webkit-gtk_svn.bb
+++ /dev/null
@@ -1,71 +0,0 @@
-DESCRIPTION = "WebKit browser engine, GTK+ edition"
-DEPENDS = "libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
-
-SRCREV_FORMAT = "webcore-rwebkit"
-
-# Yes, this is wrong...
-PV = "0.1+svnr${SRCREV}"
-PR = "r8"
-
-SRC_URI = "\
- svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http;name=webcore \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
- svn://svn.webkit.org/repository/webkit/trunk/;module=autotools;proto=http \
- file://Makefile \
- file://Makefile.shared \
- file://autogen.sh \
- file://configure.ac \
- file://symbols.filter \
- file://GNUmakefile.am \
- "
-
-S = "${WORKDIR}/"
-
-inherit autotools pkgconfig lib_package
-
-export BISON="${STAGING_BINDIR_NATIVE}/bison"
-ARM_INSTRUCTION_SET = "arm"
-EXTRA_OECONF = "\
- --enable-debug=no \
- --enable-svg \
- --enable-icon-database=yes \
- --with-http-backend=soup \
- "
-EXTRA_AUTORECONF = " -I autotools "
-
-# Dolt gets used on x86 and ppc and hardcodes 'libtool'
-do_configure_append() {
- cp ${TARGET_PREFIX}libtool libtool || true
-}
-
-do_compile_prepend() {
- mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
- mkdir -p ${S}/Programs/
- cd ${S}/JavaScriptCore/pcre
- if test -e dftables.c
- then
- ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
- elif test -e dftables.cpp
- then
- ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
- fi
- cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
- cp dftables ${S}/Programs/
- cd ${S}
-}
-
-do_stage() {
- autotools_stage_all
-}
-
-PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
-FILES_${PN}launcher = "${bindir}/GtkLauncher"
-FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
-FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
-FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
-
-