summaryrefslogtreecommitdiff
path: root/packages/vnc/tightvnc_1.3.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/vnc/tightvnc_1.3.9.bb')
-rw-r--r--packages/vnc/tightvnc_1.3.9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/vnc/tightvnc_1.3.9.bb b/packages/vnc/tightvnc_1.3.9.bb
new file mode 100644
index 0000000000..ec6a7057d9
--- /dev/null
+++ b/packages/vnc/tightvnc_1.3.9.bb
@@ -0,0 +1,25 @@
+DESCRIPTION-${PN}-viewer = "A lightweight VNC viewer"
+HOMEPAGE = "http://www.tightvnc.com/"
+DEPENDS = "virtual/libx11 zlib libxmu libxaw"
+LICENSE = "GPL"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.gz \
+ file://Makefile"
+
+S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
+
+PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
+FILES_${PN}-viewer-dbg = "${bindir}/.debug"
+FILES_${PN}-viewer = "${bindir}/${PN}viewer"
+
+do_compile () {
+ install ${WORKDIR}/Makefile ${S}
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${PN}viewer ${D}${bindir}
+}