summaryrefslogtreecommitdiff
path: root/packages/vnc/tightvnc_1.3.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/vnc/tightvnc_1.3.9.bb')
-rw-r--r--packages/vnc/tightvnc_1.3.9.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/packages/vnc/tightvnc_1.3.9.bb b/packages/vnc/tightvnc_1.3.9.bb
index 3f11763fad..58ca15e1f7 100644
--- a/packages/vnc/tightvnc_1.3.9.bb
+++ b/packages/vnc/tightvnc_1.3.9.bb
@@ -3,16 +3,17 @@ HOMEPAGE = "http://www.tightvnc.com/"
DEPENDS = "virtual/libx11 zlib libxmu libxaw"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.gz \
- file://Makefile"
+ file://Makefile \
+ file://Vncviewer"
S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
FILES_${PN}-viewer-dbg = "${bindir}/.debug"
-FILES_${PN}-viewer = "${bindir}/${PN}viewer"
+FILES_${PN}-viewer = "${bindir}/${PN}viewer ${sysconfdir}"
do_compile () {
install ${WORKDIR}/Makefile ${S}
@@ -22,6 +23,8 @@ do_compile () {
do_install () {
install -d ${D}${bindir}
install ${PN}viewer ${D}${bindir}
+ install -d ${D}${sysconfdir}/X11/app-defaults
+ install -m 644 ${WORKDIR}/Vncviewer ${D}${sysconfdir}/X11/app-defaults/Vncviewer
}
pkg_postinst_${PN}-viewer () {