summaryrefslogtreecommitdiff
path: root/packages/vlc/vlc.inc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/vlc/vlc.inc')
-rw-r--r--packages/vlc/vlc.inc63
1 files changed, 0 insertions, 63 deletions
diff --git a/packages/vlc/vlc.inc b/packages/vlc/vlc.inc
deleted file mode 100644
index 511d22675e..0000000000
--- a/packages/vlc/vlc.inc
+++ /dev/null
@@ -1,63 +0,0 @@
-DESCRIPTION = "Video player and streamer - davinci edition"
-HOMEPAGE = "http://www.videolan.org"
-LICENSE = "GPL"
-PRIORITY = "optional"
-SECTION = "multimedia"
-
-DEPENDS = "libfribidi libtool hal gettext libgcrypt schroedinger libsdl-x11 qt4-x11-free dbus libxml2 gnutls tremor faad2 ffmpeg flac \
- ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag liba52 mpeg2dec', d)}"
-
-SRC_URI = "http://download.videolan.org/pub/videolan/vlc/${PV}/vlc-${PV}.tar.bz2"
-
-inherit autotools
-
-ARM_INSTRUCTION_SET = "arm"
-
-EXTRA_OECONF = "\
- --enable-libtool \
- --with-contrib \
- --enable-run-as-root \
- --disable-wxwidgets \
- --enable-x11 --enable-xvideo \
- --disable-screen --disable-caca \
- --enable-httpd --enable-vlm \
- --enable-freetype \
- --enable-sdl \
- --enable-png \
- --enable-live555 --enable-tremor \
- --enable-v4l2 --enable-v4l --disable-aa --enable-wma --disable-faad \
- --enable-dbus \
- --enable-hal \
- --without-contrib \
- --disable-opengl --disable-glx \
- --enable-realrtsp \
- ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
- ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
- ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \
-"
-
-
-do_configure() {
- cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/
- ./bootstrap
- gnu-configize --force
- libtoolize --force
- #autoreconf --force -i
- cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/
- oe_runconf
- rm config.log
- sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
- sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
-}
-
-do_stage() {
- autotools_stage_all
-}
-
-
-FILES_${PN} += "${bindir}/vlc \
- ${datadir}/applications \
- ${datadir}/vlc/ \
- "
-
-FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"